Plugins · privatecontent-free · data as of 2026-11-04
Is PrivateContent Free safe? Known vulnerabilities and latest version
- Latest version
- 1.6.0
- Last updated
- 2026-09-09
- Active installs
- 30+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Restrict pages, posts, and menus by user level or login status. Create private areas for members or logged-in users with ease and for free! — by LCweb
What to do
- Update to the latest version (1.6.0). Anything older than 1.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get privatecontent-free --field=version shows what you run; wp plugin update privatecontent-free updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-4025 · published 2026-04-08
Stored cross-site scripting (XSS) in PrivateContent Free (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.3.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PrivateContent Free plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'align' shortcode attribute in the [pc-login-form] shortcode in all versions up to, and including, 1.2.0. This is due to insufficient input sanitization and output escaping on the 'align' attribute. Specifically, the attribute value flows from the shortcode through pc_login_form() to pc_static::form_align(), where it is directly concatenated into an HTML class attribute without esc_attr() or any escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-4025Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-09-09 — latest release on wordpress.org (1.6.0).
- 2026-04-08 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4025), fixed in 1.3.0.
Get an email when PrivateContent Free has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PrivateContent Free (privatecontent-free) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/privatecontent-free (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/privatecontent-free"><img src="https://laskyr.com/plugins/privatecontent-free/badge.svg" alt="PrivateContent Free vulnerability status"></a>