Skip to content
Laskyr

Plugins · private-comment · data as of 2026-11-04

Is Private Comment safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.0.5)

As of 2026-11-04. 1 issue is on record for older versions; version 0.0.5 or newer fixes all of them that state a fix.

Latest version
0.0.5
Last updated
2026-10-29
Active installs
60+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Allow commenters to choose restrict their comments exhibition only to site owners — by Ederson Peka

What to do

  1. Update to the latest version (0.0.5). Anything older than 0.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get private-comment --field=version shows what you run; wp plugin update private-comment updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-2281 · published 2026-02-18

Stored cross-site scripting (XSS) in Private Comment (0.0.4 and older)

Affected
0.0.4 and older
Fixed in
0.0.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Private Comment plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Label text' setting in all versions up to, and including, 0.0.4. This is due to insufficient input sanitization and output escaping on the plugin's label text option. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-2281Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Private Comment vulnerability status badge
<a href="https://laskyr.com/plugins/private-comment"><img src="https://laskyr.com/plugins/private-comment/badge.svg" alt="Private Comment vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit