Plugins · prismatic · data as of 2026-11-04
Is Prismatic safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-09
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate prismatic && wp plugin delete prismatic
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
high 7.2 CVE-2026-3876 · published 2026-04-16
Stored cross-site scripting (XSS) in Prismatic (3.7.3 and older)
- Affected
- 3.7.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Prismatic plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'prismatic_encoded' pseudo-shortcode in all versions up to, and including, 3.7.3. This is due to insufficient input sanitization and output escaping on user-supplied attributes within the 'prismatic_decode' function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page by submitting a comment containing a crafted 'prismatic_encoded' pseudo-shortcode.
medium 5.4 CVE-2021-24408 · published 2021-07-12
Cross-site scripting (XSS) in Prismatic (older than 2.8)
- Affected
- older than 2.8
- Fixed in
- 2.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Prismatic WordPress plugin before 2.8 does not sanitise or validate some of its shortcode parameters, allowing users with a role as low as Contributor to set Cross-Site payload in them. A post made by a contributor would still have to be approved by an admin to have the XSS trigger able in the frontend, however, higher privilege users, such as editor could exploit this without the need of approval, and even when the blog disallows the unfiltered_html capability.
medium 6.1 CVE-2021-24409 · published 2021-07-12
Reflected cross-site scripting (XSS) in Prismatic (older than 2.8)
- Affected
- older than 2.8
- Fixed in
- 2.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Prismatic WordPress plugin before 2.8 does not escape the 'tab' GET parameter before outputting it back in an attribute, leading to a reflected Cross-Site Scripting issue which will be executed in the context of a logged in administrator
Recent activity
- 2026-08-09 — closed on wordpress.org (Author Request).
- 2026-04-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3876), fix version not stated.
- 2021-07-12 — Cross-site scripting (XSS) disclosed (CVE-2021-24408), fixed in 2.8.
- 2021-07-12 — Reflected cross-site scripting (XSS) disclosed (CVE-2021-24409), fixed in 2.8.
Get an email when Prismatic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Prismatic (prismatic) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/prismatic (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/prismatic"><img src="https://laskyr.com/plugins/prismatic/badge.svg" alt="Prismatic vulnerability status"></a>