Skip to content
Laskyr

Plugins · printful-shipping-for-woocommerce · data as of 2026-11-04

Is Printful Integration for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.12)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.12 or newer fixes all of them that state a fix.

Latest version
2.2.12
Last updated
2026-01-14
Active installs
50,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

Grow your store with the top print-on-demand dropshipping plugin — by printful

What to do

  1. Update to the latest version (2.2.12). Anything older than 2.2.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get printful-shipping-for-woocommerce --field=version shows what you run; wp plugin update printful-shipping-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-12375 · published 2026-02-19

Server-side request forgery (SSRF) in Printful Integration for WooCommerce (2.2.11 and older)

Affected
2.2.11 and older
Fixed in
2.2.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Printful Integration for WooCommerce plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.2.11 via the advanced size chart REST API endpoint. This is due to insufficient validation of user-supplied URLs before passing them to the download_url() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.

NVD CVE-2025-12375Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2022-47168 · published 2024-12-13

Missing authorization check in Printful Integration for WooCommerce (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in printful Printful Integration for WooCommerce printful-shipping-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Printful Integration for WooCommerce: from n/a through <= 2.2.3.

NVD CVE-2022-47168Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Printful Integration for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/printful-shipping-for-woocommerce"><img src="https://laskyr.com/plugins/printful-shipping-for-woocommerce/badge.svg" alt="Printful Integration for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit