Skip to content
Laskyr

Plugins · printfriendly · data as of 2026-11-04

Is Print, PDF & Email by PrintFriendly safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.5.13)

As of 2026-11-04. 2 issues are on record for older versions; version 5.5.11 or newer fixes all of them that state a fix.

Latest version
5.5.13
Last updated
2026-09-11
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

The #1 Print, PDF, Email button. Stylish, full featured, customizable. Add custom header, footer, and more. — by Print & PDF by PrintFriendly

What to do

  1. Update to the latest version (5.5.13). Anything older than 5.5.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get printfriendly --field=version shows what you run; wp plugin update printfriendly updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-9738 · published 2026-07-11

Stored cross-site scripting (XSS) in Print, PDF & Email by PrintFriendly (5.5.10 and older)

Affected
5.5.10 and older
Fixed in
5.5.11 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Print, PDF, Email by PrintFriendly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content_position_css' parameter in all versions up to, and including, 5.5.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-9738Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2023-25032 · published 2023-10-25

Stored cross-site scripting (XSS) in Print, PDF & Email by PrintFriendly (5.5.1 and older)

Affected
5.5.1 and older
Fixed in
5.5.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Print, PDF, Email by PrintFriendly plugin <= 5.5.1 versions.

NVD CVE-2023-25032Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Print, PDF & Email by PrintFriendly vulnerability status badge
<a href="https://laskyr.com/plugins/printfriendly"><img src="https://laskyr.com/plugins/printfriendly/badge.svg" alt="Print, PDF & Email by PrintFriendly vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit