Skip to content
Laskyr

Plugins · prevent-file-access · data as of 2026-11-04

Is Prevent Files / Folders Access safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.6.8 or newer fixes all of them that state a fix.

Latest version
2.7.0
Last updated
2026-10-12
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Prevent public access to WordPress files and folders. Protect downloads from public access. Role and user based folder access in premium plans only. — by miniOrange

What to do

  1. Update to the latest version (2.7.0). Anything older than 2.6.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get prevent-file-access --field=version shows what you run; wp plugin update prevent-file-access updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-97267 · published 2026-09-30

Missing authorization check in Prevent Files / Folders Access (2.6.7 and older)

Affected
2.6.7 and older
Fixed in
2.6.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in Prevent files / folders access <= 2.6.7 versions.

NVD CVE-2026-97267Patchstack advisory

medium 6.5 CVE-2025-53561 · published 2025-08-20

Path traversal / file read in Prevent Files / Folders Access (2.6.0 and older)

Affected
2.6.0 and older
Fixed in
2.6.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Path Traversal: '.../...//' vulnerability in miniOrange Prevent files / folders access prevent-file-access allows Path Traversal.This issue affects Prevent files / folders access: from n/a through <= 2.6.0.

NVD CVE-2025-53561Patchstack advisory

high 7.2 CVE-2023-4238 · published 2023-09-25

Security issue in Prevent Files / Folders Access (older than 2.5.2)

Affected
older than 2.5.2
Fixed in
2.5.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Prevent files / folders access WordPress plugin before 2.5.2 does not validate files to be uploaded, which could allow attackers to upload arbitrary files such as PHP on the server.

NVD CVE-2023-4238WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Prevent Files / Folders Access vulnerability status badge
<a href="https://laskyr.com/plugins/prevent-file-access"><img src="https://laskyr.com/plugins/prevent-file-access/badge.svg" alt="Prevent Files / Folders Access vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit