Skip to content
Laskyr

Plugins · prevent-direct-access · data as of 2026-11-04

Is Prevent Direct Access safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.9.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.8.8.9 or newer fixes all of them that state a fix.

Latest version
2.8.9.1
Last updated
2026-08-27
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

A simple way to prevent search engines and the public from indexing and accessing your files without complex user authentication. — by WP Folio Team

What to do

  1. Update to the latest version (2.8.9.1). Anything older than 2.8.8.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get prevent-direct-access --field=version shows what you run; wp plugin update prevent-direct-access updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-3835 · published 2026-08-13

Missing authorization check in Prevent Direct Access (2.8.8.8 and older)

Affected
2.8.8.8 and older
Fixed in
2.8.8.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Prevent Direct Access – Protect WordPress Files plugin for WordPress is vulnerable to unauthorized access of protected files due to insufficient token validation in the `get_advance_file_by_url()` method in all versions up to, and including, 2.8.8.8 The method uses a SQL `LIKE` operator for token lookup without escaping wildcard characters via `$wpdb->esc_like()`. This makes it possible for unauthenticated attackers to bypass the private token requirement by supplying SQL wildcard characters (such as `%`) as the token value, matching any record in the plugin's file table and downloading any protected file.

NVD CVE-2026-3835Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.3 CVE-2025-3923 · published 2025-04-25

Information disclosure in Prevent Direct Access (2.8.8 and older)

Affected
2.8.8 and older
Fixed in
2.8.8.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Prevent Direct Access – Protect WordPress Files plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.8.8 via the 'generate_unique_string' due to insufficient randomness of the generated file name. This makes it possible for unauthenticated attackers to extract sensitive data including files protected by the plugin if the attacker can determine the file name.

NVD CVE-2025-3923Wordfence advisoryplugins.svn.wordpress.orgPlugin source

medium 5.4 CVE-2025-3861 · published 2025-04-25

Missing authorization check in Prevent Direct Access (2.8.6 to 2.8.8.2)

Affected
2.8.6 to 2.8.8.2
Fixed in
2.8.8.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Prevent Direct Access – Protect WordPress Files plugin for WordPress is vulnerable to unauthorized access and modification of data| due to a misconfigured capability check on the 'pda_lite_custom_permission_check' function in versions 2.8.6 to 2.8.8.2. This makes it possible for authenticated attackers, with Contributor-level access and above, to access and change the protection status of media.

NVD CVE-2025-3861Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Prevent Direct Access vulnerability status badge
<a href="https://laskyr.com/plugins/prevent-direct-access"><img src="https://laskyr.com/plugins/prevent-direct-access/badge.svg" alt="Prevent Direct Access vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit