Plugins · pretty-link · data as of 2026-11-04
Is PrettyLinks safe? Known vulnerabilities and latest version
- Latest version
- 4.0.18
- Last updated
- 2026-10-21
- Active installs
- 200,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
🌠 Shorten, brand, and track any URL on your own domain. Keep your links — and your data — where they belong. 🔗 — by Blair Williams
What to do
- Update to the latest version (4.0.18). Anything older than 3.6.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pretty-link --field=version shows what you run; wp plugin update pretty-link updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-5062 · published 2026-08-05
SQL injection in PrettyLinks (3.6.20 and older)
- Affected
- 3.6.20 and older
- Fixed in
- 3.6.21 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PrettyLinks – Affiliate Links, Link Branding, Link Tracking, Marketing and Stripe Payments Plugin plugin for WordPress is vulnerable to SQL Injection via the 's' (search) parameter on the Pretty Links listing page in all versions up to, and including, 3.6.20. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query in the `search_links_table()` function. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-5062Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-48247 · published 2025-05-19
Missing authorization check in PrettyLinks (3.6.15 and older)
- Affected
- 3.6.15 and older
- Fixed in
- 3.6.16
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Blair Williams Shortlinks by Pretty Links pretty-link allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Shortlinks by Pretty Links: from n/a through <= 3.6.15.
high 7.1 CVE-2024-29770 · published 2024-03-27
Reflected cross-site scripting (XSS) in PrettyLinks (3.6.2 and older)
- Affected
- 3.6.2 and older
- Fixed in
- 3.6.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Pretty Links Shortlinks by Pretty Links allows Reflected XSS.This issue affects Shortlinks by Pretty Links: from n/a through 3.6.2.
medium 4.3 CVE-2024-2326 · published 2024-03-23
Cross-site request forgery (CSRF) in PrettyLinks (3.6.3 and older)
- Affected
- 3.6.3 and older
- Fixed in
- 3.6.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Pretty Links – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.6.3. This is due to missing or incorrect nonce validation when saving plugin settings. This makes it possible for unauthenticated attackers to change the plugin's configuration including stripe integration via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
medium 6.1 CVE-2019-25147 · published 2023-06-07
Stored cross-site scripting (XSS) in PrettyLinks (older than 2.1.10)
- Affected
- older than 2.1.10
- Fixed in
- 2.1.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Pretty Links plugin for WordPress is vulnerable to Stored Cross-Site Scripting via various IP headers as well as the referer header in versions up to, and including, 2.1.9 due to insufficient input sanitization and output escaping in the track_link function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2019-25147Wordfence advisoryCode change (fix)blog.nintechnet.com
high 8.8 CVE-2022-47149 · published 2023-05-25
Cross-site request forgery (CSRF) in PrettyLinks (3.4.0 and older)
- Affected
- 3.4.0 and older
- Fixed in
- 3.4.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Pretty Links plugin <= 3.4.0 versions.
Recent activity
- 2026-10-21 — latest release on wordpress.org (4.0.18).
- 2026-08-05 — SQL injection disclosed (CVE-2026-5062), fixed in 3.6.21.
- 2025-05-19 — Missing authorization check disclosed (CVE-2025-48247), fixed in 3.6.16.
- 2024-03-27 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-29770), fixed in 3.6.3.
Get an email when PrettyLinks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PrettyLinks (pretty-link) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Blair Williams (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (2) · SQL injection (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pretty-link (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pretty-link"><img src="https://laskyr.com/plugins/pretty-link/badge.svg" alt="PrettyLinks vulnerability status"></a>