Skip to content
Laskyr

Plugins · pretty-google-calendar · data as of 2026-11-04

Is Pretty Google Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.1 or newer fixes all of them that state a fix.

Latest version
2.2.1
Last updated
2026-01-04
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Embedded Google Calendars that don't suck. — by LBell

What to do

  1. Update to the latest version (2.2.1). Anything older than 2.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pretty-google-calendar --field=version shows what you run; wp plugin update pretty-google-calendar updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-12898 · published 2025-12-20

Missing authorization check in Pretty Google Calendar (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.0.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Pretty Google Calendar plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the pgcal_ajax_handler() function in all versions up to, and including, 2.0.0. This makes it possible for unauthenticated attackers to retrieve the Google API key set in the plugin's settings.

NVD CVE-2025-12898Wordfence advisoryCode change (fix)wordpress.org

medium 6.5 CVE-2024-33640 · published 2024-04-29

Stored cross-site scripting (XSS) in Pretty Google Calendar (1.7.2 and older)

Affected
1.7.2 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LBell Pretty Google Calendar allows Stored XSS.This issue affects Pretty Google Calendar: from n/a through 1.7.2.

NVD CVE-2024-33640Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Pretty Google Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/pretty-google-calendar"><img src="https://laskyr.com/plugins/pretty-google-calendar/badge.svg" alt="Pretty Google Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit