Plugins · presto-player · data as of 2026-11-04
Is Presto Player safe? Known vulnerabilities and latest version
- Latest version
- 4.5.4
- Last updated
- 2026-10-15
- Active installs
- 100,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A modern video and audio player for courses, landing pages, marketing, and testimonials — with captions, branding, and page-builder support. — by Andre Gagnon
What to do
- Update to the latest version (4.5.4). Anything older than 4.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get presto-player --field=version shows what you run; wp plugin update presto-player updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-109893 · published 2026-10-15
Stored cross-site scripting (XSS) in Presto Player (4.5.3 and older)
- Affected
- 4.5.3 and older
- Fixed in
- 4.5.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Presto Player presto-player allows Stored XSS.This issue affects Presto Player: from n/a through 4.5.3.
high 7.2 CVE-2026-96682 · published 2026-10-10
Stored cross-site scripting (XSS) in Presto Player (4.5.1 and older)
- Affected
- 4.5.1 and older
- Fixed in
- 4.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Presto Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via <presto-player> Tag in all versions up to, and including, 4.5.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an initial comment approval, though WordPress default settings will auto-approve all subsequent comments from the same author, allowing a patient unauthenticated attacker to land the payload without further admin intervention.
NVD CVE-2026-96682Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-102914 · published 2026-10-05
Stored cross-site scripting (XSS) in Presto Player (4.5.2 and older)
- Affected
- 4.5.2 and older
- Fixed in
- 4.5.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Presto Player presto-player allows Stored XSS.This issue affects Presto Player: from n/a through 4.5.2.
medium 6.4 CVE-2026-9125 · published 2026-06-12
Stored cross-site scripting (XSS) in Presto Player (4.2.0 and older)
- Affected
- 4.2.0 and older
- Fixed in
- 4.2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Presto Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'link_url' parameter of the [presto_player_overlay] shortcode in versions up to, and including, 4.2.0 This is due to insufficient input sanitization and output escaping in the getOverlays() function, which copies the link_url shortcode attribute directly into the overlay configuration without scheme validation, allowing javascript: URIs to survive and be rendered as the href of a clickable anchor element by the presto-dynamic-overlay-ui web component. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-9125Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source
medium 4.3 CVE-2026-45442 · published 2026-05-19
Missing authorization check in Presto Player (4.1.3 and older)
- Affected
- 4.1.3 and older
- Fixed in
- 4.1.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Brainstorm Force Presto Player allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Presto Player: from n/a through 4.1.3.
medium 6.3 CVE-2024-43285 · published 2024-11-01
Missing authorization check in Presto Player (3.0.2 and older)
- Affected
- 3.0.2 and older
- Fixed in
- 3.0.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Presto Made, Inc Presto Player allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Presto Player: from n/a through 3.0.2.
Recent activity
- 2026-10-15 — latest release on wordpress.org (4.5.4).
- 2026-10-15 — Stored cross-site scripting (XSS) disclosed (CVE-2026-109893), fixed in 4.5.4.
- 2026-10-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-96682), fixed in 4.5.2.
- 2026-10-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-102914), fixed in 4.5.3.
Get an email when Presto Player has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Presto Player (presto-player) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/presto-player (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/presto-player"><img src="https://laskyr.com/plugins/presto-player/badge.svg" alt="Presto Player vulnerability status"></a>