Skip to content
Laskyr

Plugins · pressprimer-quiz · data as of 2026-11-04

Is PressPrimer Quiz safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.3)

As of 2026-11-04. 1 issue is on record for older versions; version 2.3.1 or newer fixes all of them that state a fix.

Latest version
3.1.3
Last updated
2026-10-13
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Enterprise-grade quiz and assessment platform for educators with AI question generation, LMS integration, and modern themes. — by PressPrimer

What to do

  1. Update to the latest version (3.1.3). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pressprimer-quiz --field=version shows what you run; wp plugin update pressprimer-quiz updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-10623 · published 2026-06-18

Missing authorization check in PressPrimer Quiz (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PressPrimer Quiz – AI Quiz Maker, Exam Builder & LMS Assessment Plugin plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.3.0 via the 'rule_id' parameter due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with custom-level access and above, to modify or delete quiz rules belonging to other teachers, resulting in unauthorized tampering of another user's quiz structure.

NVD CVE-2026-10623Wordfence advisorygithub.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PressPrimer Quiz vulnerability status badge
<a href="https://laskyr.com/plugins/pressprimer-quiz"><img src="https://laskyr.com/plugins/pressprimer-quiz/badge.svg" alt="PressPrimer Quiz vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit