Plugins · press3d · data as of 2026-11-04
Is Press3D safe? Known vulnerabilities and latest version
- Latest version
- 1.2.1
- Last updated
- 2026-09-02
- Active installs
- 40+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Display interactive 3D models (STL, OBJ, GLB, GLTF) with Gutenberg blocks and shortcodes. — by arieslab
What to do
- Update to the latest version (1.2.1). Anything older than 1.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get press3d --field=version shows what you run; wp plugin update press3d updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-1985 · published 2026-02-14
Stored cross-site scripting (XSS) in Press3D (1.0.2 and older)
- Affected
- 1.0.2 and older
- Fixed in
- 1.1.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Press3D plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 3D Model Gutenberg block in all versions up to, and including, 1.0.2. This is due to the plugin failing to sanitize and validate the URL scheme when storing link URLs for 3D model blocks, allowing `javascript:` URLs. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages via the link URL parameter that will execute whenever a user clicks on the 3D model.
NVD CVE-2026-1985Wordfence advisorycwe.mitre.orgdeveloper.wordpress.orgPlugin source
Recent activity
- 2026-09-02 — latest release on wordpress.org (1.2.1).
- 2026-02-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-1985), fixed in 1.1.0.
Get an email when Press3D has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Press3D (press3d) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/press3d (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/press3d"><img src="https://laskyr.com/plugins/press3d/badge.svg" alt="Press3D vulnerability status"></a>