Skip to content
Laskyr

Plugins · premmerce-woocommerce-wishlist · data as of 2026-11-04

Is Premmerce Wishlist for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.17)

As of 2026-11-04. 5 issues are on record for older versions; version 1.1.15 or newer fixes all of them that state a fix.

Latest version
1.1.17
Last updated
2026-10-31
Active installs
100+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

This plugin provides the possibility for your customers to create wishlists with the further possibility to share them with friends. — by Premmerce

What to do

  1. Update to the latest version (1.1.17). Anything older than 1.1.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get premmerce-woocommerce-wishlist --field=version shows what you run; wp plugin update premmerce-woocommerce-wishlist updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-97273 · published 2026-10-01

Cross-site scripting (XSS) in Premmerce Wishlist for WooCommerce (1.1.13 and older)

Affected
1.1.13 and older
Fixed in
1.1.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Premmerce Wishlist for WooCommerce <= 1.1.13 versions.

NVD CVE-2026-97273Patchstack advisory

high 7.1 CVE-2026-97268 · published 2026-10-01

Cross-site scripting (XSS) in Premmerce Wishlist for WooCommerce (1.1.13 and older)

Affected
1.1.13 and older
Fixed in
1.1.15
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Premmerce Wishlist for WooCommerce <= 1.1.13 versions.

NVD CVE-2026-97268Patchstack advisory

critical 9.3 CVE-2026-54849 · published 2026-06-25

SQL injection in Premmerce Wishlist for WooCommerce (1.1.11 and older)

Affected
1.1.11 and older
Fixed in
1.1.12
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Premmerce Wishlist for WooCommerce <= 1.1.11 versions.

NVD CVE-2026-54849Patchstack advisory

medium 5.3 CVE-2025-13440 · published 2025-12-12

Missing authorization check in Premmerce Wishlist for WooCommerce (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Premmerce Wishlist for WooCommerce plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.1.10. This is due to a missing capability check on the deleteWishlist() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary wishlists.

NVD CVE-2025-13440Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2025-60191 · published 2025-11-06

File inclusion in Premmerce Wishlist for WooCommerce (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Premmerce Premmerce Wishlist for WooCommerce premmerce-woocommerce-wishlist allows PHP Local File Inclusion.This issue affects Premmerce Wishlist for WooCommerce: from n/a through <= 1.1.10.

NVD CVE-2025-60191Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Premmerce Wishlist for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/premmerce-woocommerce-wishlist"><img src="https://laskyr.com/plugins/premmerce-woocommerce-wishlist/badge.svg" alt="Premmerce Wishlist for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit