Skip to content
Laskyr

Plugins · premmerce-woocommerce-wholesale-pricing · data as of 2026-11-04

Is Premmerce Wholesale Pricing for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.16)

As of 2026-11-04. 3 issues are on record for older versions; version 1.1.11 or newer fixes all of them that state a fix.

Latest version
1.1.16
Last updated
2026-10-31
Active installs
400+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Premmerce Wholesale Pricing for WooCommerce is a plugin that allows you to add individual wholesale prices or other price types for WooCommerce produc … — by Premmerce

What to do

  1. Update to the latest version (1.1.16). Anything older than 1.1.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get premmerce-woocommerce-wholesale-pricing --field=version shows what you run; wp plugin update premmerce-woocommerce-wholesale-pricing updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2025-12411 · published 2025-11-18

SQL injection in Premmerce Wholesale Pricing for WooCommerce (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Premmerce Wholesale Pricing for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the 'ID' parameter in versions up to, and including, 1.1.10. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber level access and above, to manipulate SQL queries that can be used to extract sensitive information from the database and modify price type display names in the database via the admin-post.php "premmerce_update_price_type" action, causing cosmetic corruption of the admin interface. The 'price_type' parameter of the "premmerce_delete_price_type" is also vulnerable.

NVD CVE-2025-12411Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2025-60192 · published 2025-11-06

File inclusion in Premmerce Wholesale Pricing for WooCommerce (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Premmerce Premmerce Wholesale Pricing for WooCommerce premmerce-woocommerce-wholesale-pricing allows PHP Local File Inclusion.This issue affects Premmerce Wholesale Pricing for WooCommerce: from n/a through <= 1.1.10.

NVD CVE-2025-60192Patchstack advisory

medium 5.4 CVE-2025-64285 · published 2025-10-29

Missing authorization check in Premmerce Wholesale Pricing for WooCommerce (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Premmerce Premmerce Wholesale Pricing for WooCommerce premmerce-woocommerce-wholesale-pricing allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premmerce Wholesale Pricing for WooCommerce: from n/a through <= 1.1.10.

NVD CVE-2025-64285Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Premmerce Wholesale Pricing for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/premmerce-woocommerce-wholesale-pricing"><img src="https://laskyr.com/plugins/premmerce-woocommerce-wholesale-pricing/badge.svg" alt="Premmerce Wholesale Pricing for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit