Skip to content
Laskyr

Plugins · premmerce-woocommerce-brands · data as of 2026-11-04

Is Premmerce Brands for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.16)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.14 or newer fixes all of them that state a fix.

Latest version
1.2.16
Last updated
2026-10-07
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

This plugin makes it possible to create an unlimited number of brands that can be assigned to the products for better cataloging. — by Premmerce

What to do

  1. Update to the latest version (1.2.16). Anything older than 1.2.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get premmerce-woocommerce-brands --field=version shows what you run; wp plugin update premmerce-woocommerce-brands updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12783 · published 2025-12-12

Missing authorization check in Premmerce Brands for WooCommerce (1.2.13 and older)

Affected
1.2.13 and older
Fixed in
1.2.14 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Premmerce Brands for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the saveBrandsSettings function in all versions up to, and including, 1.2.13. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify brand permalink settings.

NVD CVE-2025-12783Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-62890 · published 2025-10-27

Cross-site request forgery (CSRF) in Premmerce Brands for WooCommerce (1.2.13 and older)

Affected
1.2.13 and older
Fixed in
1.2.14
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Premmerce Premmerce Brands for WooCommerce premmerce-woocommerce-brands allows Cross Site Request Forgery.This issue affects Premmerce Brands for WooCommerce: from n/a through <= 1.2.13.

NVD CVE-2025-62890Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Premmerce Brands for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/premmerce-woocommerce-brands"><img src="https://laskyr.com/plugins/premmerce-woocommerce-brands/badge.svg" alt="Premmerce Brands for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit