Plugins · premmerce-user-roles · data as of 2026-11-04
Is Premmerce User Roles safe? Known vulnerabilities and latest version
- Latest version
- 1.0.17
- Last updated
- 2026-10-31
- Active installs
- 600+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
This plugin has been developed for creating user roles from the WordPress admin area and assigning the arbitrary access rights to them. — by Premmerce
What to do
- Update to the latest version (1.0.17). Anything older than 1.0.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get premmerce-user-roles --field=version shows what you run; wp plugin update premmerce-user-roles updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2025-60193 · published 2025-11-06
File inclusion in Premmerce User Roles (1.0.13 and older)
- Affected
- 1.0.13 and older
- Fixed in
- 1.0.14
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Premmerce Premmerce User Roles premmerce-user-roles allows PHP Local File Inclusion.This issue affects Premmerce User Roles: from n/a through <= 1.0.13.
medium 5.9 CVE-2025-64291 · published 2025-10-29
Stored cross-site scripting (XSS) in Premmerce User Roles (1.0.13 and older)
- Affected
- 1.0.13 and older
- Fixed in
- 1.0.14
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Premmerce Premmerce User Roles premmerce-user-roles allows Stored XSS.This issue affects Premmerce User Roles: from n/a through <= 1.0.13.
medium 4.3 CVE-2025-62883 · published 2025-10-27
Missing authorization check in Premmerce User Roles (1.0.13 and older)
- Affected
- 1.0.13 and older
- Fixed in
- 1.0.14
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Premmerce Premmerce User Roles premmerce-user-roles allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premmerce User Roles: from n/a through <= 1.0.13.
high 8.1 CVE-2023-41130 · published 2024-12-13
Missing authorization check in Premmerce User Roles (1.0.12 and older)
- Affected
- 1.0.12 and older
- Fixed in
- 1.0.13
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Premmerce Premmerce User Roles premmerce-user-roles allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premmerce User Roles: from n/a through <= 1.0.12.
Recent activity
- 2026-10-31 — latest release on wordpress.org (1.0.17).
- 2025-11-06 — File inclusion disclosed (CVE-2025-60193), fixed in 1.0.14.
- 2025-10-29 — Stored cross-site scripting (XSS) disclosed (CVE-2025-64291), fixed in 1.0.14.
- 2025-10-27 — Missing authorization check disclosed (CVE-2025-62883), fixed in 1.0.14.
Get an email when Premmerce User Roles has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Premmerce User Roles (premmerce-user-roles) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Premmerce (9 tracked)
Types found in this plugin: Missing authorization (2) · File inclusion (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/premmerce-user-roles (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/premmerce-user-roles"><img src="https://laskyr.com/plugins/premmerce-user-roles/badge.svg" alt="Premmerce User Roles vulnerability status"></a>