Plugins · premmerce-redirect-manager · data as of 2026-11-04
Is Premmerce Redirect Manager safe? Known vulnerabilities and latest version
- Latest version
- 1.0.17
- Last updated
- 2026-10-31
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
The Premmerce Redirect Manager enables you to create 301 and 302 redirects and to set up the automatic redirects for the deleted products in the WooCo … — by Premmerce
What to do
- Update to the latest version (1.0.17). Anything older than 1.0.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get premmerce-redirect-manager --field=version shows what you run; wp plugin update premmerce-redirect-manager updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-32541 · published 2026-03-25
Missing authorization check in Premmerce Redirect Manager (1.0.12 and older)
- Affected
- 1.0.12 and older
- Fixed in
- 1.0.13
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- advisory text · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Premmerce Premmerce Redirect Manager premmerce-redirect-manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Premmerce Redirect Manager: from n/a through <= 1.0.12.
high 8.8 CVE-2023-23787 · published 2023-07-10
Cross-site request forgery (CSRF) in Premmerce Redirect Manager (1.0.9 and older)
- Affected
- 1.0.9 and older
- Fixed in
- 1.0.10 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Premmerce Premmerce Redirect Manager plugin <= 1.0.9 versions.
medium 4.8 CVE-2023-23789 · published 2023-05-10
Stored cross-site scripting (XSS) in Premmerce Redirect Manager (1.0.9 and older)
- Affected
- 1.0.9 and older
- Fixed in
- 1.0.10 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Premmerce Premmerce Redirect Manager plugin <= 1.0.9 versions.
Recent activity
- 2026-10-31 — latest release on wordpress.org (1.0.17).
- 2026-03-25 — Missing authorization check disclosed (CVE-2026-32541), fixed in 1.0.13.
- 2023-07-10 — Cross-site request forgery (CSRF) disclosed (CVE-2023-23787), fixed in 1.0.10.
- 2023-05-10 — Stored cross-site scripting (XSS) disclosed (CVE-2023-23789), fixed in 1.0.10.
Get an email when Premmerce Redirect Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Premmerce Redirect Manager (premmerce-redirect-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Premmerce (9 tracked)
Types found in this plugin: Missing authorization (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/premmerce-redirect-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/premmerce-redirect-manager"><img src="https://laskyr.com/plugins/premmerce-redirect-manager/badge.svg" alt="Premmerce Redirect Manager vulnerability status"></a>