Plugins · premmerce · data as of 2026-11-04
Is Premmerce safe? Known vulnerabilities and latest version
- Latest version
- 1.3.24
- Last updated
- 2026-10-07
- Active installs
- 400+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.9+
Premmerce is a must-have toolkit for WooCommerce with a detailed Setup Wizard for your store. — by Premmerce
What to do
- Update to the latest version (1.3.24). Anything older than 1.3.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get premmerce --field=version shows what you run; wp plugin update premmerce updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-0555 · published 2026-02-07
Stored cross-site scripting (XSS) in Premmerce (1.3.20 and older)
- Affected
- 1.3.20 and older
- Fixed in
- 1.3.21 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Premmerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'premmerce_wizard_actions' AJAX endpoint in all versions up to, and including, 1.3.20. This is due to missing capability checks and insufficient input sanitization and output escaping on the `state` parameter. This makes it possible for authenticated attackers, with subscriber level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page (the Premmerce Wizard admin page).
NVD CVE-2026-0555Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2025-60241 · published 2025-11-06
File inclusion in Premmerce (1.3.19 and older)
- Affected
- 1.3.19 and older
- Fixed in
- 1.3.20
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Premmerce Premmerce premmerce allows PHP Local File Inclusion.This issue affects Premmerce: from n/a through <= 1.3.19.
medium 4.3 CVE-2025-64288 · published 2025-10-29
Cross-site request forgery (CSRF) in Premmerce (1.3.19 and older)
- Affected
- 1.3.19 and older
- Fixed in
- 1.3.20
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Premmerce Premmerce premmerce allows Cross Site Request Forgery.This issue affects Premmerce: from n/a through <= 1.3.19.
high 8.8 CVE-2023-23719 · published 2023-07-17
Cross-site request forgery (CSRF) in Premmerce (1.3.17 and older)
- Affected
- 1.3.17 and older
- Fixed in
- 1.3.18 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Premmerce plugin <= 1.3.17 versions.
Recent activity
- 2026-10-07 — latest release on wordpress.org (1.3.24).
- 2026-02-07 — Stored cross-site scripting (XSS) disclosed (CVE-2026-0555), fixed in 1.3.21.
- 2025-11-06 — File inclusion disclosed (CVE-2025-60241), fixed in 1.3.20.
- 2025-10-29 — Cross-site request forgery (CSRF) disclosed (CVE-2025-64288), fixed in 1.3.20.
Get an email when Premmerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Premmerce (premmerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Premmerce (9 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Cross-site scripting (XSS) (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/premmerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/premmerce"><img src="https://laskyr.com/plugins/premmerce/badge.svg" alt="Premmerce vulnerability status"></a>