Plugins · premium-blocks-for-gutenberg · data as of 2026-11-04
Is Premium Blocks safe? Known vulnerabilities and latest version
- Latest version
- 2.3.18
- Last updated
- 2026-09-21
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Premium Blocks for Gutenberg: Free Gutenberg blocks packed with performance-optimized tools, global styling options, responsive controls, pre-built te … — by Leap13
What to do
- Update to the latest version (2.3.18). Anything older than 2.3.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get premium-blocks-for-gutenberg --field=version shows what you run; wp plugin update premium-blocks-for-gutenberg updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-94118 · published 2026-09-23
Cross-site scripting (XSS) in Premium Blocks (2.3.17 and older)
- Affected
- 2.3.17 and older
- Fixed in
- 2.3.18 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Premium Blocks – Gutenberg Blocks for WordPress <= 2.3.17 versions.
medium 6.5 CVE-2024-56245 · published 2025-01-02
Stored cross-site scripting (XSS) in Premium Blocks (2.1.42 and older)
- Affected
- 2.1.42 and older
- Fixed in
- 2.1.43 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Leap13 Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Stored XSS.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through <= 2.1.42.
medium 6.5 CVE-2024-47368 · published 2024-10-06
Stored cross-site scripting (XSS) in Premium Blocks (2.1.33 and older)
- Affected
- 2.1.33 and older
- Fixed in
- 2.1.34 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Leap13 Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg allows Stored XSS.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through <= 2.1.33.
medium 5.4 CVE-2024-37519 · published 2024-07-21
Cross-site scripting (XSS) in Premium Blocks (2.1.27 and older)
- Affected
- 2.1.27 and older
- Fixed in
- 2.1.28 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Leap13 Premium Blocks – Gutenberg Blocks for WordPress premium-blocks-for-gutenberg.This issue affects Premium Blocks – Gutenberg Blocks for WordPress: from n/a through <= 2.1.27.
Recent activity
- 2026-09-21 — latest release on wordpress.org (2.3.18).
- 2026-09-23 — Cross-site scripting (XSS) disclosed (CVE-2026-94118), fixed in 2.3.18.
- 2025-01-02 — Stored cross-site scripting (XSS) disclosed (CVE-2024-56245), fixed in 2.1.43.
- 2024-10-06 — Stored cross-site scripting (XSS) disclosed (CVE-2024-47368), fixed in 2.1.34.
Get an email when Premium Blocks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Premium Blocks (premium-blocks-for-gutenberg) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Leap13 (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/premium-blocks-for-gutenberg (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/premium-blocks-for-gutenberg"><img src="https://laskyr.com/plugins/premium-blocks-for-gutenberg/badge.svg" alt="Premium Blocks vulnerability status"></a>