Skip to content
Laskyr

Plugins · preferred-languages · data as of 2026-11-04

Is Preferred Languages safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.2)

As of 2026-11-04. 1 issue is on record for older versions; version 2.3.0 or newer fixes all of them that state a fix.

Latest version
2.4.2
Last updated
2026-08-18
Active installs
3,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2.24+

Choose languages for displaying WordPress in, in order of preference. — by Pascal Birchler

What to do

  1. Update to the latest version (2.4.2). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get preferred-languages --field=version shows what you run; wp plugin update preferred-languages updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2024-35644 · published 2026-03-06

Cross-site scripting (XSS) in Preferred Languages (2.2.2 and older)

Affected
2.2.2 and older
Fixed in
2.3.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Pascal Birchler Preferred Languages allows DOM-Based XSS.This issue affects Preferred Languages: from n/a through 2.2.2.

NVD CVE-2024-35644Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Preferred Languages vulnerability status badge
<a href="https://laskyr.com/plugins/preferred-languages"><img src="https://laskyr.com/plugins/preferred-languages/badge.svg" alt="Preferred Languages vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit