Skip to content
Laskyr

Plugins · pre-orders-for-woocommerce · data as of 2026-11-04

Is Pre-Orders for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.1 or newer fixes all of them that state a fix.

Latest version
2.3.1
Last updated
2026-09-07
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Ultimate Pre-Orders Plugin for WooCommerce. — by brightvesseldev

What to do

  1. Update to the latest version (2.3.1). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pre-orders-for-woocommerce --field=version shows what you run; wp plugin update pre-orders-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-84849 · published 2026-09-03

Security issue in Pre-Orders for WooCommerce (2.3 and older)

Affected
2.3 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Pre-Orders for WooCommerce <= 2.3 versions.

NVD CVE-2026-84849Patchstack advisory

medium 5.4 CVE-2023-46783 · published 2023-11-06

Stored cross-site scripting (XSS) in Pre-Orders for WooCommerce (1.2.13 and older)

Affected
1.2.13 and older
Fixed in
1.2.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Bright Plugins Pre-Orders for WooCommerce plugin <= 1.2.13 versions.

NVD CVE-2023-46783Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Pre-Orders for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/pre-orders-for-woocommerce"><img src="https://laskyr.com/plugins/pre-orders-for-woocommerce/badge.svg" alt="Pre-Orders for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit