Plugins · powerpack-addon-for-beaver-builder · data as of 2026-11-04
Is PowerPack Lite for Beaver Builder safe? Known vulnerabilities and latest version
- Latest version
- 1.3.2
- Last updated
- 2026-10-15
- Active installs
- 6,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
PowerPack Lite for Beaver Builder extends Beaver Builder with custom options, unique modules and templates. — by IdeaBox Creations
What to do
- Update to the latest version (1.3.2). Anything older than 1.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get powerpack-addon-for-beaver-builder --field=version shows what you run; wp plugin update powerpack-addon-for-beaver-builder updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-110897 · published 2026-10-18
Stored cross-site scripting (XSS) in PowerPack Lite for Beaver Builder (1.3.1 and older)
- Affected
- 1.3.1 and older
- Fixed in
- 1.3.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IdeaBox Creations PowerPack Lite for Beaver Builder powerpack-addon-for-beaver-builder allows Stored XSS.This issue affects PowerPack Lite for Beaver Builder: from n/a through 1.3.1.
medium 6.1 CVE-2024-12239 · published 2024-12-17
Reflected cross-site scripting (XSS) in PowerPack Lite for Beaver Builder (1.3.0.5 and older)
- Affected
- 1.3.0.5 and older
- Fixed in
- 1.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PowerPack Lite for Beaver Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the navigate parameter in all versions up to, and including, 1.3.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick an administrative user into performing an action such as clicking on a link.
medium 5.4 CVE-2024-37409 · published 2024-07-22
Cross-site scripting (XSS) in PowerPack Lite for Beaver Builder (1.3.0.4 and older)
- Affected
- 1.3.0.4 and older
- Fixed in
- 1.3.0.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in IdeaBox Creations PowerPack Lite for Beaver Builder powerpack-addon-for-beaver-builder.This issue affects PowerPack Lite for Beaver Builder: from n/a through <= 1.3.0.4.
high 7.2 CVE-2024-37410 · published 2024-07-09
File inclusion in PowerPack Lite for Beaver Builder (1.3.0.3 and older)
- Affected
- 1.3.0.3 and older
- Fixed in
- 1.3.0.4
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in IdeaBox Creations PowerPack Lite for Beaver Builder powerpack-addon-for-beaver-builder.This issue affects PowerPack Lite for Beaver Builder: from n/a through <= 1.3.0.3.
medium 5.4 CVE-2024-2289 · published 2024-04-09
Stored cross-site scripting (XSS) in PowerPack Lite for Beaver Builder (1.3.0 and older)
- Affected
- 1.3.0 and older
- Fixed in
- 1.3.0.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The PowerPack Lite for Beaver Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the link in multiple elements in all versions up to, and including, 1.3.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.1 CVE-2022-0176 · published 2022-02-14
Reflected cross-site scripting (XSS) in PowerPack Lite for Beaver Builder (older than 1.2.9.3)
- Affected
- older than 1.2.9.3
- Fixed in
- 1.2.9.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The PowerPack Lite for Beaver Builder WordPress plugin before 1.2.9.3 does not sanitise and escape the tab parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting
Recent activity
- 2026-10-15 — latest release on wordpress.org (1.3.2).
- 2026-10-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-110897), fixed in 1.3.2.
- 2024-12-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-12239), fixed in 1.3.1.
- 2024-07-22 — Cross-site scripting (XSS) disclosed (CVE-2024-37409), fixed in 1.3.0.5.
Get an email when PowerPack Lite for Beaver Builder has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PowerPack Lite for Beaver Builder (powerpack-addon-for-beaver-builder) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by IdeaBox Creations (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/powerpack-addon-for-beaver-builder (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/powerpack-addon-for-beaver-builder"><img src="https://laskyr.com/plugins/powerpack-addon-for-beaver-builder/badge.svg" alt="PowerPack Lite for Beaver Builder vulnerability status"></a>