Plugins · powerkit · data as of 2026-11-04
Is Powerkit safe? Known vulnerabilities and latest version
- Latest version
- 3.1.1
- Last updated
- 2026-07-31
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.4+
Essential components for every WordPress site: share buttons, social links, social media integrations, galleries, lazyload, custom widgets, and more. — by codesupplyco
What to do
- Update to the latest version (3.1.1). Anything older than 3.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get powerkit --field=version shows what you run; wp plugin update powerkit updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2390 · published 2026-09-07
Stored cross-site scripting (XSS) in Powerkit (3.0.4 and older)
- Affected
- 3.0.4 and older
- Fixed in
- 3.0.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Powerkit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Lazy Load module's image processing in all versions up to, and including, 3.0.4. This is due to the 'content_process_images' function using a flawed regex-based HTML attribute parser. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-2390Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-28178 · published 2026-08-06
Cross-site scripting (XSS) in Powerkit (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Powerkit <= 3.1.0 versions.
medium 6.4 CVE-2026-15644 · published 2026-08-01
Stored cross-site scripting (XSS) in Powerkit (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Powerkit – Supercharge your WordPress Site plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'style' Shortcode Attribute in all versions up to, and including, 3.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15644Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-15645 · published 2026-08-01
Stored cross-site scripting (XSS) in Powerkit (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Powerkit – Supercharge your WordPress Site plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'nav' Shortcode Attribute in all versions up to, and including, 3.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15645Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-15649 · published 2026-08-01
Stored cross-site scripting (XSS) in Powerkit (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Powerkit – Supercharge your WordPress Site plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 3.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15649Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-2458 · published 2024-04-06
Stored cross-site scripting (XSS) in Powerkit (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- 2.9.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Powerkit – Supercharge your WordPress Site plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 2.9.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-07-31 — latest release on wordpress.org (3.1.1).
- 2026-09-07 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2390), fixed in 3.0.5.
- 2026-08-06 — Cross-site scripting (XSS) disclosed (CVE-2026-28178), fixed in 3.1.1.
- 2026-08-01 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15644), fixed in 3.1.1.
Get an email when Powerkit has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Powerkit (powerkit) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by codesupplyco (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (6)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/powerkit (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/powerkit"><img src="https://laskyr.com/plugins/powerkit/badge.svg" alt="Powerkit vulnerability status"></a>