Skip to content
Laskyr

Plugins · posts-data-table · data as of 2026-11-04

Is Posts Table with Search & Sort safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.15)

As of 2026-11-04. 2 issues are on record for older versions; version 1.4.15 or newer fixes all of them that state a fix.

Latest version
1.4.15
Last updated
2026-11-02
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Automatically create searchable and sortable tables of your posts. — by Barn2 Plugins

What to do

  1. Update to the latest version (1.4.15). Anything older than 1.4.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get posts-data-table --field=version shows what you run; wp plugin update posts-data-table updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-120843 · published 2026-11-03

Stored cross-site scripting (XSS) in Posts Table with Search & Sort (1.4.14 and older)

Affected
1.4.14 and older
Fixed in
1.4.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Stored XSS.This issue affects Posts Table with Search & Sort: from n/a through 1.4.14.

NVD CVE-2026-120843Patchstack advisory

medium 5.3 CVE-2025-58613 · published 2025-09-03

Missing authorization check in Posts Table with Search & Sort (1.4.10 and older)

Affected
1.4.10 and older
Fixed in
1.4.11
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Posts Table with Search & Sort: from n/a through <= 1.4.10.

NVD CVE-2025-58613Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Posts Table with Search & Sort vulnerability status badge
<a href="https://laskyr.com/plugins/posts-data-table"><img src="https://laskyr.com/plugins/posts-data-table/badge.svg" alt="Posts Table with Search & Sort vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit