Plugins · postmarkapp-email-integrator · data as of 2026-11-04
Is PostmarkApp Email Integrator safe? Known vulnerabilities and latest version
- Latest version
- 2.5.0
- Last updated
- 2026-03-23
- Active installs
- 50+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Enables your WordPress site to send emails via PostMarkApp API. — by Gagan Deep Singh
What to do
- Update to the latest version (2.5.0). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get postmarkapp-email-integrator --field=version shows what you run; wp plugin update postmarkapp-email-integrator updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2026-1043 · published 2026-02-19
Stored cross-site scripting (XSS) in PostmarkApp Email Integrator (2.4 and older)
- Affected
- 2.4 and older
- Fixed in
- 2.5.0 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PostmarkApp Email Integrator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin settings in versions up to, and including, 2.4. This is due to insufficient input sanitization and output escaping on the pma_api_key and pma_sender_address parameters. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the settings page.
high 7.1 CVE-2025-31617 · published 2025-03-31
Cross-site request forgery (CSRF) in PostmarkApp Email Integrator (2.4 and older)
- Affected
- 2.4 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Gagan Deep Singh PostmarkApp Email Integrator postmarkapp-email-integrator allows Cross Site Request Forgery.This issue affects PostmarkApp Email Integrator: from n/a through <= 2.4.
medium 4.3 CVE-2025-31576 · published 2025-03-31
Missing authorization check in PostmarkApp Email Integrator (2.4 and older)
- Affected
- 2.4 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Gagan Deep Singh PostmarkApp Email Integrator postmarkapp-email-integrator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PostmarkApp Email Integrator: from n/a through <= 2.4.
Recent activity
- 2026-03-23 — latest release on wordpress.org (2.5.0).
- 2026-02-19 — Stored cross-site scripting (XSS) disclosed (CVE-2026-1043), fixed in 2.5.0.
- 2025-03-31 — Cross-site request forgery (CSRF) disclosed (CVE-2025-31617), fixed in 2.5.0.
- 2025-03-31 — Missing authorization check disclosed (CVE-2025-31576), fixed in 2.5.0.
Get an email when PostmarkApp Email Integrator has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PostmarkApp Email Integrator (postmarkapp-email-integrator) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/postmarkapp-email-integrator (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/postmarkapp-email-integrator"><img src="https://laskyr.com/plugins/postmarkapp-email-integrator/badge.svg" alt="PostmarkApp Email Integrator vulnerability status"></a>