Plugins · postie · data as of 2026-11-04
Is Postie safe? Known vulnerabilities and latest version
- Latest version
- 1.9.88
- Last updated
- 2026-10-23
- Active installs
- 10,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
Postie allows you to create posts via email, including many advanced features not found in WordPress's default Post by Email feature. — by Wayne Allen
What to do
- Update to the latest version (1.9.88). Anything older than 1.9.88 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get postie --field=version shows what you run; wp plugin update postie updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-100175 · published 2026-10-28
Stored cross-site scripting (XSS) in Postie (1.9.87 and older)
- Affected
- 1.9.87 and older
- Fixed in
- 1.9.88 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Postie plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Email Body URL Autolink in all versions up to, and including, 1.9.87 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the ?postie=get-mail endpoint is reachable by unauthenticated users with no capability check, and the email processing path removes WordPress's kses output filters before saving raw markup, allowing the unescaped href attribute value to be stored as post content.
NVD CVE-2026-100175Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-63020 · published 2025-12-31
Stored cross-site scripting (XSS) in Postie (1.9.73 and older)
- Affected
- 1.9.73 and older
- Fixed in
- 1.9.74
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wayne Allen Postie postie allows Stored XSS.This issue affects Postie: from n/a through <= 1.9.73.
medium 4.8 CVE-2024-5200 · published 2025-09-29
Stored cross-site scripting (XSS) in Postie (older than 1.9.71)
- Affected
- older than 1.9.71
- Fixed in
- 1.9.71
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Postie WordPress plugin before 1.9.71 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 5.4 CVE-2019-20204 · published 2020-01-02
Cross-site scripting (XSS) in Postie (1.9.40 and older)
- Affected
- 1.9.40 and older
- Fixed in
- 1.9.42 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Postie plugin 1.9.40 for WordPress allows XSS, as demonstrated by a certain payload with jaVasCript:/* at the beginning and a crafted SVG element.
NVD CVE-2019-20204wordpress.orgpacketstormsecurity.comgithub.compostieplugin.comwpvulndb.com
medium 5.3 CVE-2019-20203 · published 2020-01-02
Security issue in Postie (1.9.40 and older)
- Affected
- 1.9.40 and older
- Fixed in
- 1.9.42 *
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Authorized Addresses feature in the Postie plugin 1.9.40 for WordPress allows remote attackers to publish posts by spoofing the From information of an email message.
NVD CVE-2019-20203wordpress.orggithub.compostieplugin.comwpvulndb.com
Recent activity
- 2026-10-23 — latest release on wordpress.org (1.9.88).
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-100175), fixed in 1.9.88.
- 2025-12-31 — Stored cross-site scripting (XSS) disclosed (CVE-2025-63020), fixed in 1.9.74.
- 2025-09-29 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5200), fixed in 1.9.71.
Get an email when Postie has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Postie (postie) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/postie (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/postie"><img src="https://laskyr.com/plugins/postie/badge.svg" alt="Postie vulnerability status"></a>