Skip to content
Laskyr

Plugins · postaffiliatepro · data as of 2026-11-04

Is Post Affiliate Pro safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.29.5)

As of 2026-11-04. 2 issues are on record for older versions; version 1.28.1 or newer fixes all of them that state a fix.

Latest version
1.29.5
Last updated
2026-10-06
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

The plugin integrates any WordPress with a Post Affiliate Pro account. Post Affiliate Pro is the leading affiliate tracking tool worldwide. — by qusupport

What to do

  1. Update to the latest version (1.29.5). Anything older than 1.28.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get postaffiliatepro --field=version shows what you run; wp plugin update postaffiliatepro updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 3.8 CVE-2026-2290 · published 2026-03-21

Server-side request forgery (SSRF) in Post Affiliate Pro (1.28.0 and older)

Affected
1.28.0 and older
Fixed in
1.28.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Post Affiliate Pro plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.28.0. This makes it possible for authenticated attackers, with Administrator-level access, to make web requests to initiate arbitrary outbound requests from the application and read the returned response content. Successful exploitation was confirmed by receiving and observing response data from an external Collaborator endpoint.

NVD CVE-2026-2290Wordfence advisoryPlugin source

medium 4.8 CVE-2023-38482 · published 2023-09-03

Stored cross-site scripting (XSS) in Post Affiliate Pro (1.25.0 and older)

Affected
1.25.0 and older
Fixed in
1.26.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in QualityUnit Post Affiliate Pro plugin <= 1.25.0 versions.

NVD CVE-2023-38482Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Post Affiliate Pro vulnerability status badge
<a href="https://laskyr.com/plugins/postaffiliatepro"><img src="https://laskyr.com/plugins/postaffiliatepro/badge.svg" alt="Post Affiliate Pro vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit