Skip to content
Laskyr

Plugins · post-type-switcher · data as of 2026-11-04

Is Post Type Switcher safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 4.0.1 or newer fixes all of them that state a fix.

Latest version
4.1.1
Last updated
2026-10-15
Active installs
200,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

A simple way to change a post's type in WordPress — by John James Jacoby

What to do

  1. Update to the latest version (4.1.1). Anything older than 4.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get post-type-switcher --field=version shows what you run; wp plugin update post-type-switcher updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-12524 · published 2025-11-18

Missing authorization check in Post Type Switcher (4.0.0 and older)

Affected
4.0.0 and older
Fixed in
4.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Post Type Switcher plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to, and including, 4.0.0 due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Author-level access and above, to modify the post type of arbitrary posts and pages they do not own, including those created by administrators, which can lead to site disruption, broken navigation, and SEO impact.

NVD CVE-2025-12524Wordfence advisoryCode change (fix)cwe.mitre.orgowasp.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Post Type Switcher vulnerability status badge
<a href="https://laskyr.com/plugins/post-type-switcher"><img src="https://laskyr.com/plugins/post-type-switcher/badge.svg" alt="Post Type Switcher vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit