Plugins · post-type-archive-mapping · data as of 2026-11-04
Is Custom Query Blocks safe? Known vulnerabilities and latest version
- Latest version
- 5.7.0
- Last updated
- 2026-10-09
- Active installs
- 700+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Map your archives to pages. Map 404 and term archives as well. — by Ronald Huereca
What to do
- Update to the latest version (5.7.0). Anything older than 5.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get post-type-archive-mapping --field=version shows what you run; wp plugin update post-type-archive-mapping updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-108168 · published 2026-10-12
Stored cross-site scripting (XSS) in Custom Query Blocks (5.6.0 and older)
- Affected
- 5.6.0 and older
- Fixed in
- 5.7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in DLX Plugins Custom Query Blocks post-type-archive-mapping allows Stored XSS.This issue affects Custom Query Blocks: from n/a through 5.6.0.
medium 6.5 CVE-2026-39575 · published 2026-04-08
Cross-site scripting (XSS) in Custom Query Blocks (5.5.0 and older)
- Affected
- 5.5.0 and older
- Fixed in
- 5.6.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ronald Huereca Custom Query Blocks post-type-archive-mapping allows DOM-Based XSS.This issue affects Custom Query Blocks: from n/a through <= 5.5.0.
medium 5.3 CVE-2024-38794 · published 2024-11-01
Missing authorization check in Custom Query Blocks (5.2.0 and older)
- Affected
- 5.2.0 and older
- Fixed in
- 5.3.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in MediaRon LLC Custom Query Blocks allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Custom Query Blocks: from n/a through 5.2.0.
medium 5.4 CVE-2024-44059 · published 2024-09-15
Cross-site scripting (XSS) in Custom Query Blocks (5.3.1 and older)
- Affected
- 5.3.1 and older
- Fixed in
- 5.4.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ronald Huereca Custom Query Blocks post-type-archive-mapping allows DOM-Based XSS.This issue affects Custom Query Blocks: from n/a through <= 5.3.1.
Recent activity
- 2026-10-09 — latest release on wordpress.org (5.7.0).
- 2026-10-12 — Stored cross-site scripting (XSS) disclosed (CVE-2026-108168), fixed in 5.7.0.
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39575), fixed in 5.6.0.
- 2024-11-01 — Missing authorization check disclosed (CVE-2024-38794), fixed in 5.3.0.
Get an email when Custom Query Blocks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Custom Query Blocks (post-type-archive-mapping) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/post-type-archive-mapping (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/post-type-archive-mapping"><img src="https://laskyr.com/plugins/post-type-archive-mapping/badge.svg" alt="Custom Query Blocks vulnerability status"></a>