Plugins · post-timeline · data as of 2026-11-04
Is Post Timeline safe? Known vulnerabilities and latest version
- Latest version
- 2.4.3
- Last updated
- 2026-08-20
- Active installs
- 700+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Create stunning and interactive timelines for your WordPress posts with ease. Post Timeline is the ultimate plugin for displaying your WordPress conte … — by Agile Logix
What to do
- Update to the latest version (2.4.3). Anything older than 2.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get post-timeline --field=version shows what you run; wp plugin update post-timeline updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-32421 · published 2026-03-13
Missing authorization check in Post Timeline (2.4.1 and older)
- Affected
- 2.4.1 and older
- Fixed in
- 2.4.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Agile Logix Post Timeline post-timeline allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Post Timeline: from n/a through <= 2.4.1.
high 7.1 CVE-2024-13571 · published 2025-02-26
Reflected cross-site scripting (XSS) in Post Timeline (older than 2.3.10)
- Affected
- older than 2.3.10
- Fixed in
- 2.3.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Post Timeline WordPress plugin before 2.3.10 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
high 7.1 CVE-2025-24614 · published 2025-02-14
Reflected cross-site scripting (XSS) in Post Timeline (2.3.9 and older)
- Affected
- 2.3.9 and older
- Fixed in
- 2.3.10
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Agile Logix Post Timeline post-timeline allows Reflected XSS.This issue affects Post Timeline: from n/a through <= 2.3.9.
medium 6.1 CVE-2023-4284 · published 2023-09-04
Reflected cross-site scripting (XSS) in Post Timeline (older than 2.2.6)
- Affected
- older than 2.2.6
- Fixed in
- 2.2.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Post Timeline WordPress plugin before 2.2.6 does not sanitise and escape an invalid nonce before outputting it back in an AJAX response, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Recent activity
- 2026-08-20 — latest release on wordpress.org (2.4.3).
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-32421), fixed in 2.4.2.
- 2025-02-26 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-13571), fixed in 2.3.10.
- 2025-02-14 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-24614), fixed in 2.3.10.
Get an email when Post Timeline has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Post Timeline (post-timeline) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Agile Logix (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/post-timeline (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/post-timeline"><img src="https://laskyr.com/plugins/post-timeline/badge.svg" alt="Post Timeline vulnerability status"></a>