Skip to content
Laskyr

Plugins · post-carousel · data as of 2026-11-04

Is Smart Post safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.10)

As of 2026-11-04. 4 issues are on record for older versions; version 4.0.10 or newer fixes all of them that state a fix.

Latest version
4.0.10
Last updated
2026-10-30
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

Display posts in Grid, Carousel, Slider, Timeline, List & Live Filter layouts with Gutenberg Blocks & Ready Patterns - Elementor, Divi, & Shortcodes. — by ShapedPlugin LLC

What to do

  1. Update to the latest version (4.0.10). Anything older than 4.0.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get post-carousel --field=version shows what you run; wp plugin update post-carousel updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-119160 · published 2026-10-31

Stored cross-site scripting (XSS) in Smart Post (4.0.9 and older)

Affected
4.0.9 and older
Fixed in
4.0.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name' parameter in all versions up to, and including, 4.0.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the victim page to contain an Author Filter block alongside a grid or live-filter block, and execution is triggered by a visitor clicking the attacker's author entry in the dropdown — a standard filter interaction requiring no elevated privileges from the victim.

NVD CVE-2026-119160Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2026-78149 · published 2026-09-05

Information disclosure in Smart Post (4.0.0 up to (not including) 4.0.8)

Affected
4.0.0 up to (not including) 4.0.8
Fixed in
4.0.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Smart Post WordPress plugin before 4.0.8 does not check whether a post is password protected before returning its content and its stored password through an unauthenticated AJAX action, allowing unauthenticated users to read protected post content and the password that guards it.

NVD CVE-2026-78149WPScan advisory

low 2.7 CVE-2026-78150 · published 2026-09-05

Missing authorization check in Smart Post (4.0.0 up to (not including) 4.0.8)

Affected
4.0.0 up to (not including) 4.0.8
Fixed in
4.0.8
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Smart Post WordPress plugin before 4.0.8 does not check the type, ownership or status of the post it is asked to duplicate, allowing users with contributor privileges and above to copy any private or password protected post into a draft of their own and read its content and metadata.

NVD CVE-2026-78150WPScan advisory

high 7.2 CVE-2026-3017 · published 2026-04-14

PHP object injection in Smart Post (3.0.12 and older)

Affected
3.0.12 and older
Fixed in
3.0.13 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Post Show – Post Grid, Post Carousel & Slider, and List Category Posts plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.0.12 via deserialization of untrusted input in the import_shortcodes() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2026-3017Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smart Post vulnerability status badge
<a href="https://laskyr.com/plugins/post-carousel"><img src="https://laskyr.com/plugins/post-carousel/badge.svg" alt="Smart Post vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit