Skip to content
Laskyr

Plugins · popup-box · data as of 2026-11-04

Is Popup Box safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.15)

As of 2026-11-04. 3 issues are on record for older versions; version 3.2.13 or newer fixes all of them that state a fix.

Latest version
3.2.15
Last updated
2026-08-25
Active installs
6,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Popup Box lets you create responsive, customizable WordPress popups with live preview, flexible triggers, and smart targeting to boost engagement and … — by Wow-Company

What to do

  1. Update to the latest version (3.2.15). Anything older than 3.2.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get popup-box --field=version shows what you run; wp plugin update popup-box updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-12122 · published 2026-02-18

Stored cross-site scripting (XSS) in Popup Box (3.2.12 and older)

Affected
3.2.12 and older
Fixed in
3.2.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Popup Box – Easily Create WordPress Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'iframeBox' shortcode in all versions up to, and including, 3.2.12 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12122Wordfence advisoryCode change (fix)

medium 5.4 CVE-2025-24711 · published 2025-01-24

Cross-site request forgery (CSRF) in Popup Box (3.2.4 and older)

Affected
3.2.4 and older
Fixed in
3.2.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Wow-Company Popup Box popup-box allows Cross Site Request Forgery.This issue affects Popup Box: from n/a through <= 3.2.4.

NVD CVE-2025-24711Patchstack advisory

high 7.2 CVE-2022-29445 · published 2022-05-18

File inclusion in Popup Box (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
2.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (administrator or higher role) Local File Inclusion (LFI) vulnerability in Wow-Company's Popup Box plugin <= 2.1.2 at WordPress.

NVD CVE-2022-29445Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Popup Box vulnerability status badge
<a href="https://laskyr.com/plugins/popup-box"><img src="https://laskyr.com/plugins/popup-box/badge.svg" alt="Popup Box vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit