Skip to content
Laskyr

Plugins · popup-addon-for-ninja-forms · data as of 2026-11-04

Is Popup addon for Ninja Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.2)

As of 2026-11-04. 2 issues are on record for older versions; version 3.5.2 or newer fixes all of them that state a fix.

Latest version
3.5.2
Last updated
2025-11-04
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

Popup/Modal addon for Ninja Forms. Create beautiful popups using Ninja Forms for newsletters, login, registration forms. — by Aman

What to do

  1. Update to the latest version (3.5.2). Anything older than 3.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get popup-addon-for-ninja-forms --field=version shows what you run; wp plugin update popup-addon-for-ninja-forms updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-64264 · published 2025-11-13

Stored cross-site scripting (XSS) in Popup addon for Ninja Forms (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aman Popup addon for Ninja Forms popup-addon-for-ninja-forms allows Stored XSS.This issue affects Popup addon for Ninja Forms: from n/a through <= 3.5.1.

NVD CVE-2025-64264Patchstack advisory

medium 6.5 CVE-2025-53279 · published 2025-06-27

Cross-site scripting (XSS) in Popup addon for Ninja Forms (3.4 and older)

Affected
3.4 and older
Fixed in
3.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aman Popup addon for Ninja Forms popup-addon-for-ninja-forms allows DOM-Based XSS.This issue affects Popup addon for Ninja Forms: from n/a through <= 3.4.

NVD CVE-2025-53279Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Popup addon for Ninja Forms vulnerability status badge
<a href="https://laskyr.com/plugins/popup-addon-for-ninja-forms"><img src="https://laskyr.com/plugins/popup-addon-for-ninja-forms/badge.svg" alt="Popup addon for Ninja Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit