Plugins · popularis-extra · data as of 2026-11-04
Is Popularis Extra safe? Known vulnerabilities and latest version
- Latest version
- 1.2.10
- Last updated
- 2025-12-03
- Active installs
- 6,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 5.6+
Popularis Extra add extra features to Popularis theme like demo import, widgets, shortcodes or Elementor widgets. — by Themes4WP
What to do
- There is no fixed version yet. If you can live without Popularis Extra for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get popularis-extra --field=version shows what you run; wp plugin update popularis-extra updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 affects latest 1.2.10 CVE-2026-25422 · published 2026-02-19
Cross-site request forgery (CSRF) in Popularis Extra (1.2.10 and older)
- Affected
- 1.2.10 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Themes4WP Popularis Extra popularis-extra allows Cross Site Request Forgery.This issue affects Popularis Extra: from n/a through <= 1.2.10.
medium 4.3 CVE-2024-10795 · published 2024-11-16
Information disclosure in Popularis Extra (1.2.7 and older)
- Affected
- 1.2.7 and older
- Fixed in
- 1.2.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Popularis Extra plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.2.7 via the 'elementor-template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created via Elementor that they should not have access to.
medium 6.1 CVE-2024-9353 · published 2024-10-04
Reflected cross-site scripting (XSS) in Popularis Extra (1.2.6 and older)
- Affected
- 1.2.6 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Popularis Extra plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg & remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.2.6. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-9353Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-12-03 — latest release on wordpress.org (1.2.10).
- 2026-02-19 — Cross-site request forgery (CSRF) disclosed (CVE-2026-25422), no fix listed yet.
- 2024-11-16 — Information disclosure disclosed (CVE-2024-10795), fixed in 1.2.8.
- 2024-10-04 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-9353), fixed in 1.2.7.
Get an email when Popularis Extra has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Popularis Extra (popularis-extra) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1) · Sensitive data exposure (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/popularis-extra (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/popularis-extra"><img src="https://laskyr.com/plugins/popularis-extra/badge.svg" alt="Popularis Extra vulnerability status"></a>