Skip to content
Laskyr

Plugins · popcashnet-code-integration-tool · data as of 2026-11-04

Is PopCash Code Integration Tool safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0 or newer fixes all of them that state a fix.

Latest version
2.0
Last updated
2026-03-16
Active installs
300+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

This plugin is designed to help the integration of the publisher code from PopCash.Net — by PopCash

What to do

  1. Update to the latest version (2.0). Anything older than 2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get popcashnet-code-integration-tool --field=version shows what you run; wp plugin update popcashnet-code-integration-tool updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-24619 · published 2026-01-23

Missing authorization check in PopCash Code Integration Tool (1.8 and older)

Affected
1.8 and older
Fixed in
2.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in PopCash PopCash.Net Code Integration Tool popcashnet-code-integration-tool allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PopCash.Net Code Integration Tool: from n/a through <= 1.8.

NVD CVE-2026-24619Patchstack advisory

medium 6.1 CVE-2017-15810 · published 2017-10-23

Cross-site scripting (XSS) in PopCash Code Integration Tool (1.0 and older)

Affected
1.0 and older
Fixed in
1.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The PopCash.Net Code Integration Tool plugin before 1.1 for WordPress has XSS via the tab parameter to wp-admin/admin.php.

NVD CVE-2017-15810wordpress.orgpacketstormsecurity.comwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PopCash Code Integration Tool vulnerability status badge
<a href="https://laskyr.com/plugins/popcashnet-code-integration-tool"><img src="https://laskyr.com/plugins/popcashnet-code-integration-tool/badge.svg" alt="PopCash Code Integration Tool vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit