Skip to content
Laskyr

Plugins · polylang · data as of 2026-11-01

Is Polylang safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.1)

As of 2026-11-01. 6 issues are on record for older versions; version 3.8.10 or newer fixes all of them that state a fix.

Latest version
3.9.1
Last updated
2026-10-21
Active installs
900,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Go multilingual in a simple and efficient way. Keep writing posts and taxonomy terms as usual while defining their languages all at once. — by Chouby

What to do

  1. Update to the latest version (3.9.1). Anything older than 3.8.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get polylang --field=version shows what you run; wp plugin update polylang updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-97278 · published 2026-10-14

PHP object injection in Polylang (3.8.9 and older)

Affected
3.8.9 and older
Fixed in
3.8.10
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in WP SYNTEX Polylang polylang allows Object Injection.This issue affects Polylang: from n/a through 3.8.9.

NVD CVE-2026-97278Patchstack advisory

medium 4.3 CVE-2026-39783 · published 2026-10-05

Missing authorization check in Polylang (3.8.7 and older)

Affected
3.8.7 and older
Fixed in
3.8.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP SYNTEX Polylang polylang allows Retrieve Embedded Sensitive Data.This issue affects Polylang: from n/a through 3.8.7.

NVD CVE-2026-39783Patchstack advisory

medium 6.5 CVE-2026-97279 · published 2026-09-30

Cross-site scripting (XSS) in Polylang (3.8.9 and older)

Affected
3.8.9 and older
Fixed in
3.8.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Polylang <= 3.8.9 versions.

NVD CVE-2026-97279Patchstack advisory

medium 4.3 CVE-2026-65458 · published 2026-07-23

Information disclosure in Polylang (3.8.5 and older)

Affected
3.8.5 and older
Fixed in
3.8.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Chouby Polylang and Chouby Polylang Pro allows Retrieve Embedded Sensitive Data. This issue affects Polylang: through 3.8.5; Polylang Pro: through 3.8.5.

NVD CVE-2026-65458Patchstack advisory

high 8.8 CVE-2025-64353 · published 2025-10-31

PHP object injection in Polylang (3.7.3 and older)

Affected
3.7.3 and older
Fixed in
3.7.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Chouby Polylang polylang allows Object Injection.This issue affects Polylang: from n/a through <= 3.7.3.

NVD CVE-2025-64353Patchstack advisory

medium 4.3 CVE-2014-4855 · published 2014-07-10

Cross-site scripting (XSS) in Polylang (1.5.1 and older, 1.5 only)

Affected
1.5.1 and older, 1.5 only
Fixed in
1.5.2 *
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site scripting (XSS) vulnerability in the Polylang plugin before 1.5.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via vectors related to a user description. NOTE: some of these details are obtained from third party information.

NVD CVE-2014-4855wordpress.orgsecunia.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Polylang vulnerability status badge
<a href="https://laskyr.com/plugins/polylang"><img src="https://laskyr.com/plugins/polylang/badge.svg" alt="Polylang vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit