Skip to content
Laskyr

Plugins · poll-wp · data as of 2026-11-04

Is TS Poll safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.0)

As of 2026-11-04. 6 issues are on record for older versions; version 2.6.0 or newer fixes all of them that state a fix.

Latest version
2.6.0
Last updated
2026-04-13
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.5+

Poll plugin is a responsive and customizable for WordPress. Poll will help you more easily create powerful poll, image & video poll, vote, results. — by totalsoft

What to do

  1. Update to the latest version (2.6.0). Anything older than 2.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get poll-wp --field=version shows what you run; wp plugin update poll-wp updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-25428 · published 2026-02-19

Server-side request forgery (SSRF) in TS Poll (2.5.5 and older)

Affected
2.5.5 and older
Fixed in
2.6.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in totalsoft TS Poll poll-wp allows Server Side Request Forgery.This issue affects TS Poll: from n/a through <= 2.5.5.

NVD CVE-2026-25428Patchstack advisory

medium 4.3 CVE-2025-68588 · published 2025-12-24

Missing authorization check in TS Poll (2.5.5 and older)

Affected
2.5.5 and older
Fixed in
2.6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in totalsoft TS Poll poll-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TS Poll: from n/a through <= 2.5.5.

NVD CVE-2025-68588Patchstack advisory

medium 4.9 CVE-2025-3470 · published 2025-04-15

SQL injection in TS Poll (2.4.6 and older)

Affected
2.4.6 and older
Fixed in
2.4.7 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TS Poll – Survey, Versus Poll, Image Poll, Video Poll plugin for WordPress is vulnerable to SQL Injection via the s parameter in all versions up to, and including, 2.4.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-3470Wordfence advisorymebroccoli.blogspot.comPlugin source

high 7.2 CVE-2024-8625 · published 2024-10-21

SQL injection in TS Poll (older than 2.4.0)

Affected
older than 2.4.0
Fixed in
2.4.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The TS Poll WordPress plugin before 2.4.0 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

NVD CVE-2024-8625WPScan advisory

high 7.2 CVE-2024-9022 · published 2024-10-10

SQL injection in TS Poll (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The TS Poll – Survey, Versus Poll, Image Poll, Video Poll plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 2.4.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-9022Wordfence advisoryCode change (fix)wordpress.orggithub.compacketstormsecurity.com

critical 9.8 CVE-2020-11673 · published 2020-04-13

Authentication bypass in TS Poll (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

An issue was discovered in the Responsive Poll through 1.3.4 for Wordpress. It allows an unauthenticated user to manipulate polls, e.g., delete, clone, or view a hidden poll. This is due to the usage of the callback wp_ajax_nopriv function in Includes/Total-Soft-Poll-Ajax.php for sensitive operations.

NVD CVE-2020-11673wordpress.orggist.github.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
TS Poll vulnerability status badge
<a href="https://laskyr.com/plugins/poll-wp"><img src="https://laskyr.com/plugins/poll-wp/badge.svg" alt="TS Poll vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit