Plugins · pojo-accessibility · data as of 2026-11-01
Is Web Accessibility (formally known as Ally) safe? Known vulnerabilities and latest version
- Latest version
- 4.1.4
- Last updated
- 2026-08-24
- Active installs
- 500,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Web Accessibility (formally known as Ally) is a free, powerful, and user-friendly plugin that helps WordPress creators build more accessible websites … — by Elementor
What to do
- Update to the latest version (4.1.4). Anything older than 4.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pojo-accessibility --field=version shows what you run; wp plugin update pojo-accessibility updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-2413 · published 2026-03-11
SQL injection in Web Accessibility (formally known as Ally) (4.0.3 and older)
- Affected
- 4.0.3 and older
- Fixed in
- 4.1.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Ally – Web Accessibility & Usability plugin for WordPress is vulnerable to SQL Injection via the URL path in all versions up to, and including, 4.0.3. This is due to insufficient escaping on the user-supplied URL parameter in the `get_global_remediations()` method, where it is directly concatenated into an SQL JOIN clause without proper sanitization for SQL context. While `esc_url_raw()` is applied for URL safety, it does not prevent SQL metacharacters (single quotes, parentheses) from being injected. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database via time-based blind SQL injection techniques. The Remediation module must be active, which requires the plugin to be connected to an Elementor account.
NVD CVE-2026-2413Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-25386 · published 2026-02-19
Missing authorization check in Web Accessibility (formally known as Ally) (4.0.2 and older)
- Affected
- 4.0.2 and older
- Fixed in
- 4.0.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Elementor Ally pojo-accessibility allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ally: from n/a through <= 4.0.2.
medium 5.9 CVE-2025-32640 · published 2025-04-09
Stored cross-site scripting (XSS) in Web Accessibility (formally known as Ally) (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.2.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Ally pojo-accessibility allows Stored XSS.This issue affects Ally: from n/a through <= 3.1.0.
Recent activity
- 2026-08-24 — latest release on wordpress.org (4.1.4).
- 2026-03-11 — SQL injection disclosed (CVE-2026-2413), fixed in 4.1.0.
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-25386), fixed in 4.0.3.
- 2025-04-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-32640), fixed in 3.2.0.
Get an email when Web Accessibility (formally known as Ally) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Web Accessibility (formally known as Ally) (pojo-accessibility) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pojo-accessibility (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pojo-accessibility"><img src="https://laskyr.com/plugins/pojo-accessibility/badge.svg" alt="Web Accessibility (formally known as Ally) vulnerability status"></a>