Skip to content
Laskyr

Plugins · podlove-web-player · data as of 2026-11-04

Is Podlove Web Player safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.10.0)

As of 2026-11-04. 3 issues are on record for older versions; version 5.9.2 or newer fixes all of them that state a fix.

Latest version
5.10.0
Last updated
2026-10-03
Active installs
4,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

A fast, flexible and responsive podcast player with chapters, transcripts and customizable themes. — by gerritvanaaken

What to do

  1. Update to the latest version (5.10.0). Anything older than 5.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get podlove-web-player --field=version shows what you run; wp plugin update podlove-web-player updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-24385 · published 2026-03-05

PHP object injection in Podlove Web Player (5.9.1 and older)

Affected
5.9.1 and older
Fixed in
5.9.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in gerritvanaaken Podlove Web Player podlove-web-player allows Object Injection.This issue affects Podlove Web Player: from n/a through <= 5.9.1.

NVD CVE-2026-24385Patchstack advisory

medium 5.3 CVE-2024-35710 · published 2024-06-08

Information disclosure in Podlove Web Player (5.7.3 and older)

Affected
5.7.3 and older
Fixed in
5.7.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Podlove Podlove Web Player.This issue affects Podlove Web Player: from n/a through 5.7.3.

NVD CVE-2024-35710Patchstack advisory

medium 6.5 CVE-2024-29788 · published 2024-03-27

Stored cross-site scripting (XSS) in Podlove Web Player (5.7.1 and older)

Affected
5.7.1 and older
Fixed in
5.7.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Podlove Podlove Web Player allows Stored XSS.This issue affects Podlove Web Player: from n/a through 5.7.1.

NVD CVE-2024-29788Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Podlove Web Player vulnerability status badge
<a href="https://laskyr.com/plugins/podlove-web-player"><img src="https://laskyr.com/plugins/podlove-web-player/badge.svg" alt="Podlove Web Player vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit