Skip to content
Laskyr

Plugins · podcast-importer-secondline · data as of 2026-11-04

Is Podcast Importer SecondLine safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.8)

As of 2026-11-04. 3 issues are on record for older versions; version 1.5.8 or newer fixes all of them that state a fix.

Latest version
1.5.8
Last updated
2026-09-21
Active installs
4,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

A simple podcast import tool for WordPress. — by SecondLineThemes

What to do

  1. Update to the latest version (1.5.8). Anything older than 1.5.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get podcast-importer-secondline --field=version shows what you run; wp plugin update podcast-importer-secondline updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-94682 · published 2026-09-23

Cross-site scripting (XSS) in Podcast Importer SecondLine (1.5.6 and older)

Affected
1.5.6 and older
Fixed in
1.5.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Podcast Importer SecondLine <= 1.5.6 versions.

NVD CVE-2026-94682Patchstack advisory

high 7.2 CVE-2022-1023 · published 2022-04-11

SQL injection in Podcast Importer SecondLine (older than 1.3.8)

Affected
older than 1.3.8
Fixed in
1.3.8
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The Podcast Importer SecondLine WordPress plugin before 1.3.8 does not sanitise and properly escape some imported data, which could allow SQL injection attacks to be performed by imported a malicious podcast file

NVD CVE-2022-1023WPScan advisoryCode change (fix)

high 7.5 CVE-2020-24149 · published 2021-07-07

Server-side request forgery (SSRF) in Podcast Importer SecondLine (1.1.4 only)

Affected
1.1.4 only
Fixed in
1.1.5 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

Server-side request forgery (SSRF) in the Podcast Importer SecondLine (podcast-importer-secondline) plugin 1.1.4 for WordPress via the podcast_feed parameter in a secondline_import_initialize action to the secondlinepodcastimport page.

NVD CVE-2020-24149wordpress.orggithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Podcast Importer SecondLine vulnerability status badge
<a href="https://laskyr.com/plugins/podcast-importer-secondline"><img src="https://laskyr.com/plugins/podcast-importer-secondline/badge.svg" alt="Podcast Importer SecondLine vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit