Plugins · pochipp · data as of 2026-11-04
Is Pochipp safe? Known vulnerabilities and latest version
- Latest version
- 1.20.3
- Last updated
- 2026-09-18
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Amazonや楽天市場から商品を検索してアフィリエイトリンクを管理できるプラグインです。 — by hiro
What to do
- Update to the latest version (1.20.3). Anything older than 1.20.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pochipp --field=version shows what you run; wp plugin update pochipp updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-92967 · published 2026-09-19
Reflected cross-site scripting (XSS) in Pochipp (1.20.2 and older)
- Affected
- 1.20.2 and older
- Fixed in
- 1.20.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Pochipp plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'keyword' parameter in versions up to, and including, 1.20.2. This is due to insufficient output escaping , which reads $_GET['keyword'], applies only sanitize_text_field() (which strips tags but leaves double quotes intact) and interpolates the value directly into the value attribute of the search input via a PHP heredoc, without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user with upload_files capability (Author or above) into performing an action such as clicking on a specially crafted link to /wp-admin/media-upload.
NVD CVE-2026-92967Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2026-32417 · published 2026-03-13
Missing authorization check in Pochipp (1.18.9 and older)
- Affected
- 1.18.9 and older
- Fixed in
- 1.18.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in wppochipp Pochipp pochipp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Pochipp: from n/a through < 1.18.9.
medium 5.3 CVE-2025-66129 · published 2025-12-16
Missing authorization check in Pochipp (1.18.0 and older)
- Affected
- 1.18.0 and older
- Fixed in
- 1.18.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in wppochipp Pochipp pochipp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Pochipp: from n/a through <= 1.18.0.
Recent activity
- 2026-09-18 — latest release on wordpress.org (1.20.3).
- 2026-09-19 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-92967), fixed in 1.20.3.
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-32417), fixed in 1.18.9.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-66129), fixed in 1.18.1.
Get an email when Pochipp has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Pochipp (pochipp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pochipp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pochipp"><img src="https://laskyr.com/plugins/pochipp/badge.svg" alt="Pochipp vulnerability status"></a>