Skip to content
Laskyr

Plugins · plugins-on-steroids · data as of 2026-11-04

Is Eazy Plugin Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.5.0 or newer fixes all of them that state a fix.

Latest version
4.5.0
Last updated
2026-08-17
Active installs
80+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.1+

Powerful Plugin Management Solution for WordPress — by EazyPlugins

What to do

  1. Update to the latest version (4.5.0). Anything older than 4.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get plugins-on-steroids --field=version shows what you run; wp plugin update plugins-on-steroids updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-14328 · published 2026-07-28

Privilege escalation in Eazy Plugin Manager (4.4.1 and older)

Affected
4.4.1 and older
Fixed in
4.5.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Eazy Plugin Manager – Powerful Plugin Management Solution for WordPress plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 4.4.1. This is due to insufficient authorization on the `wp_ajax_pos_get_option` AJAX handler, which verifies only a nonce that is localized to every logged-in admin-area user via `admin_enqueue_scripts` — without any capability check — before returning the value of any arbitrary WordPress option via `get_option()`, combined with the `admin_login_endpoint_handler` REST endpoint (`GET /wp-json/epm/v1/admin/login`) being registered as publicly accessible and authenticating callers solely by a whirlpool hash of values stored in those same options. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the `site_url`, `connection_key`, and `remote_user_id` values stored in the `eazywp_connecting_info` and `eazywp_connection` options, compute the required `auth_key`, call the `admin/login` REST endpoint to obtain Administrator authentication cookies, and fully take over the site. Exploitation requires the plugin's remote connection feature to have been configured, as the `eazywp_connecting_info` and `eazywp_connection` options must be populated with valid credentials.

NVD CVE-2026-14328Wordfence advisoryPlugin source

high 8.8 CVE-2025-32542 · published 2025-04-11

Missing authorization check in Eazy Plugin Manager (4.3.0 and older)

Affected
4.3.0 and older
Fixed in
4.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in EazyPlugins Eazy Plugin Manager plugins-on-steroids allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Eazy Plugin Manager: from n/a through <= 4.3.0.

NVD CVE-2025-32542Patchstack advisory

critical 9.9 CVE-2023-51482 · published 2024-04-25

Authentication bypass in Eazy Plugin Manager (4.1.2 and older)

Affected
4.1.2 and older
Fixed in
4.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Authentication vulnerability in EazyPlugins Eazy Plugin Manager allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Eazy Plugin Manager: from n/a through 4.1.2.

NVD CVE-2023-51482Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Eazy Plugin Manager vulnerability status badge
<a href="https://laskyr.com/plugins/plugins-on-steroids"><img src="https://laskyr.com/plugins/plugins-on-steroids/badge.svg" alt="Eazy Plugin Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit