Skip to content
Laskyr

Plugins · plugin-organizer · data as of 2026-11-04

Is Plugin Organizer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (10.2.6)

As of 2026-11-04. 2 issues are on record for older versions; version 10.2.5 or newer fixes all of them that state a fix.

Latest version
10.2.6
Last updated
2026-08-23
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Change plugin order and selectively enable/disable plugins on each post/page. — by Jeff Sterup

What to do

  1. Update to the latest version (10.2.6). Anything older than 10.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get plugin-organizer --field=version shows what you run; wp plugin update plugin-organizer updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-15304 · published 2026-07-28

SQL injection in Plugin Organizer (10.2.4 and older)

Affected
10.2.4 and older
Fixed in
10.2.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Plugin Organizer plugin for WordPress is vulnerable to SQL Injection via the 'PO_plugin_path' parameter in versions up to, and including, 10.2.4. This is due to insufficient escaping on the user-supplied parameter in the perform_plugin_search() function, where esc_sql() output is passed as the replacement string to preg_replace(), which collapses backslash escapes and defeats the quoting protection; additionally, the AJAX handler lacks both nonce verification and capability checks. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-15304Wordfence advisoryCode change (fix)Plugin source

high 8.6 CVE-2025-13417 · published 2025-12-29

SQL injection in Plugin Organizer (older than 10.2.4)

Affected
older than 10.2.4
Fixed in
10.2.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Plugin Organizer WordPress plugin before 10.2.4 does not sanitize and escape a parameter before using it in a SQL statement, allowing subscribers to perform SQL injection attacks.

NVD CVE-2025-13417WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Plugin Organizer vulnerability status badge
<a href="https://laskyr.com/plugins/plugin-organizer"><img src="https://laskyr.com/plugins/plugin-organizer/badge.svg" alt="Plugin Organizer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit