Plugins · platnosci-online-blue-media · data as of 2026-11-04
Is Autopay safe? Known vulnerabilities and latest version
- Latest version
- 5.1.0
- Last updated
- 2026-10-26
- Active installs
- 3,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Autopay is a payment module that enables cashless transactions in a shop based on the WordPress platform (WooCommerce). — by Autopay
What to do
- Update to the latest version (5.1.0). Anything older than 5.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get platnosci-online-blue-media --field=version shows what you run; wp plugin update platnosci-online-blue-media updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-90923 · published 2026-09-17
Missing authorization check in Autopay (older than 5.0.1)
- Affected
- older than 5.0.1
- Fixed in
- 5.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Autopay WordPress plugin before 5.0.1 does not enforce the signature on one of its payment callbacks, allowing unauthenticated users to disclose and delete the stored payment parameters of other customers' orders.
high 7.1 CVE-2026-73338 · published 2026-08-18
Cross-site scripting (XSS) in Autopay (5.0.0 and older)
- Affected
- 5.0.0 and older
- Fixed in
- 5.0.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Autopay <= 5.0.0 versions.
high 7.2 CVE-2026-15002 · published 2026-08-16
Stored cross-site scripting (XSS) in Autopay (5.0.0 and older)
- Affected
- 5.0.0 and older
- Fixed in
- 5.0.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Platnosci Online Blue Media (Autopay) plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 5.0.0 via the 'bm_woocommerce_css_editor_content' POST parameter. This is due to the Css_Editor::handle_save() method being wired to the WordPress 'init' hook by Settings_Manager::init_once() with no capability check, no nonce verification, and no sanitization on the input — the raw $_POST value is written to the 'woocommerce_bluemedia_settings' option via update_option(), then later echoed directly inside a <style> block on the WooCommerce checkout page by Css_Frontend::print_to_wp_head() with no output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page (the checkout page).
NVD CVE-2026-15002Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-26 — latest release on wordpress.org (5.1.0).
- 2026-09-17 — Missing authorization check disclosed (CVE-2026-90923), fixed in 5.0.1.
- 2026-08-18 — Cross-site scripting (XSS) disclosed (CVE-2026-73338), fixed in 5.0.1.
- 2026-08-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15002), fixed in 5.0.1.
Get an email when Autopay has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Autopay (platnosci-online-blue-media) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/platnosci-online-blue-media (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/platnosci-online-blue-media"><img src="https://laskyr.com/plugins/platnosci-online-blue-media/badge.svg" alt="Autopay vulnerability status"></a>