Skip to content
Laskyr

Plugins · pixmagix · data as of 2026-11-04

Is PixMagix safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.7.3 or newer fixes all of them that state a fix.

Latest version
1.7.3
Last updated
2026-06-27
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.0.0+

Advanced image editor plugin for WordPress media images. Add filters, adjust brightness and contrast, crop and resize images, add text, and much more. — by Andras Tovishati

What to do

  1. Update to the latest version (1.7.3). Anything older than 1.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pixmagix --field=version shows what you run; wp plugin update pixmagix updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-11367 · published 2026-06-30

Path traversal / file read in PixMagix (1.7.2 and older)

Affected
1.7.2 and older
Fixed in
1.7.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PixMagix – WordPress Image Editor plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.7.2 via the move_image_on_server function. This makes it possible for authenticated attackers, with author-level access and above, to write files with attacker-controlled content to arbitrary locations on the server. The unsanitized 'layers[].id' parameter is concatenated into a filesystem path and passed to PHP's copy() function, allowing traversal sequences (e.g. '../../') to escape the intended upload directory and write attacker-supplied file contents to arbitrary paths accessible by the web server process. The save_template REST endpoint is gated by the create_projects permission (edit_pixmagix + upload_files), which Author-level users hold by default after plugin activation, making this exploitable by any Author on sites running PixMagix.

NVD CVE-2026-11367Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PixMagix vulnerability status badge
<a href="https://laskyr.com/plugins/pixmagix"><img src="https://laskyr.com/plugins/pixmagix/badge.svg" alt="PixMagix vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit