Skip to content
Laskyr

Plugins · pilotpress · data as of 2026-11-04

Is PilotPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.46)

As of 2026-11-04. 4 issues are on record for older versions; version 2.0.31 or newer fixes all of them that state a fix.

Latest version
2.0.46
Last updated
2026-10-28
Active installs
900+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8

PilotPress allows you to have a website, membership site, customer center, and a partner center integrated together with ONTRAPORT. — by ONTRAPORT

What to do

  1. Update to the latest version (2.0.46). Anything older than 2.0.31 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pilotpress --field=version shows what you run; wp plugin update pilotpress updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-85659 · published 2026-10-16

Privilege escalation in PilotPress (2.0.43 and older)

Affected
2.0.43 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PilotPress plugin for WordPress is vulnerable to Privilege Escalation via Account Takeover in all versions up to, and including, 2.0.43. The vulnerability exists because the `update_cc_details()` AJAX handler forwards an attacker-supplied `username` parameter to ONTRAPORT via `api_call('update_cc_details', ...)` before performing the local `username_exists()` collision check, and aborts without rolling back the remote rename when a collision is detected — leaving the remote ONTRAPORT contact renamed to an existing WordPress Administrator's login. On a subsequent login attempt, `user_login()` (hooked to `wp_authenticate`) authenticates against ONTRAPORT using the renamed login and the attacker's own password, resolves the local WordPress user row via `get_user_by('login', $username)` — which now selects the real Administrator's row — and calls `wp_set_password()` against that Administrator's user ID; because the `user_level != 10` guard only suppresses PilotPress's own cookie issuance rather than returning a `WP_Error` to core, WordPress proceeds to validate the newly-synchronized password and issues a full Administrator authentication cookie to the attacker. This makes it possible for authenticated attackers with Subscriber-level access and above — specifically any PilotPress member holding a valid ONTRAPORT contact and the Customer Center nonce — to fully take over an Administrator account.

NVD CVE-2026-85659Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-58238 · published 2025-09-22

Stored cross-site scripting (XSS) in PilotPress (2.0.36 and older)

Affected
2.0.36 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ONTRAPORT PilotPress pilotpress allows Stored XSS.This issue affects PilotPress: from n/a through <= 2.0.36.

NVD CVE-2025-58238Patchstack advisory

medium 4.3 CVE-2025-58221 · published 2025-09-22

Missing authorization check in PilotPress (2.0.36 and older)

Affected
2.0.36 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ONTRAPORT PilotPress pilotpress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PilotPress: from n/a through <= 2.0.36.

NVD CVE-2025-58221Patchstack advisory

high 8.8 CVE-2024-23524 · published 2024-06-10

Missing authorization check in PilotPress (2.0.30 and older)

Affected
2.0.30 and older
Fixed in
2.0.31
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in ONTRAPORT Inc. PilotPress.This issue affects PilotPress: from n/a through 2.0.30.

NVD CVE-2024-23524Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PilotPress vulnerability status badge
<a href="https://laskyr.com/plugins/pilotpress"><img src="https://laskyr.com/plugins/pilotpress/badge.svg" alt="PilotPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit