Plugins · pie-forms-for-wp · data as of 2026-11-04
Is Pie Forms safe? Known vulnerabilities and latest version
- Latest version
- 1.6.4
- Last updated
- 2026-10-23
- Active installs
- 100+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.2+
The Intelligent and Easy Form Plugin. Drag & Drop form builder to help create simple to complex forms for any purpose with just a few clicks. — by Shamim Rajani
What to do
- Update to the latest version (1.6.4). Anything older than 1.6.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pie-forms-for-wp --field=version shows what you run; wp plugin update pie-forms-for-wp updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2025-12528 · published 2025-11-18
Arbitrary file upload in Pie Forms (1.6 and older)
- Affected
- 1.6 and older
- Fixed in
- 1.6.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Pie Forms for WP plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.6 via the format_classic function. This is due to insufficient file type validation where the validate_classic method validates file extensions and sets error messages but does not prevent the file upload process from continuing. This makes it possible for unauthenticated attackers to upload files with dangerous extensions such as PHP, which makes remote code execution possible. In order to exploit this vulnerability, the attacker needs to guess the directory in which the file is placed (which is a somewhat predictable hash). In addition to that, the file name is generated using a secure hash method, limiting the exploitability of this vulnerability.
medium 6.1 CVE-2024-11436 · published 2024-12-07
Reflected cross-site scripting (XSS) in Pie Forms (1.4.19 and older)
- Affected
- 1.4.19 and older
- Fixed in
- 1.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Drag & Drop Builder, Human Face Detector, Pre-built Templates, Spam Protection, User Email Notifications & more! plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'page' parameter in all versions up to, and including, 1.4.19 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Recent activity
- 2026-10-23 — latest release on wordpress.org (1.6.4).
- 2025-11-18 — Arbitrary file upload disclosed (CVE-2025-12528), fixed in 1.6.1.
- 2024-12-07 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-11436), fixed in 1.5.
Get an email when Pie Forms has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Pie Forms (pie-forms-for-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Shamim Rajani (3 tracked)
Types found in this plugin: Arbitrary file upload (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pie-forms-for-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pie-forms-for-wp"><img src="https://laskyr.com/plugins/pie-forms-for-wp/badge.svg" alt="Pie Forms vulnerability status"></a>