Plugins · picu · data as of 2026-11-04
Is picu safe? Known vulnerabilities and latest version
- Latest version
- 3.10.2
- Last updated
- 2026-10-01
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Photo proofing for professional photographers: Send a collection of photographs to your clients for approval. — by picu
What to do
- Update to the latest version (3.10.2). Anything older than 3.10.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get picu --field=version shows what you run; wp plugin update picu updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.3 CVE-2026-104406 · published 2026-10-06
Missing authorization check in picu (3.10.1 and older)
- Affected
- 3.10.1 and older
- Fixed in
- 3.10.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in picu <= 3.10.1 versions.
high 7.1 CVE-2026-104395 · published 2026-10-06
Cross-site scripting (XSS) in picu (3.10.1 and older)
- Affected
- 3.10.1 and older
- Fixed in
- 3.10.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in picu <= 3.10.1 versions.
high 7.1 CVE-2026-57387 · published 2026-07-13
Stored cross-site scripting (XSS) in picu (3.5.1 and older)
- Affected
- 3.5.1 and older
- Fixed in
- 3.6.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in picu picu picu allows Stored XSS.This issue affects picu: from n/a through <= 3.5.1.
medium 5.3 CVE-2025-24590 · published 2025-01-27
Missing authorization check in picu (2.4.0 and older)
- Affected
- 2.4.0 and older
- Fixed in
- 2.4.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in picu picu picu allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects picu: from n/a through <= 2.4.0.
Recent activity
- 2026-10-01 — latest release on wordpress.org (3.10.2).
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-104406), fixed in 3.10.2.
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-104395), fixed in 3.10.2.
- 2026-07-13 — Stored cross-site scripting (XSS) disclosed (CVE-2026-57387), fixed in 3.6.1.
Get an email when picu has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for picu (picu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/picu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/picu"><img src="https://laskyr.com/plugins/picu/badge.svg" alt="picu vulnerability status"></a>