Skip to content
Laskyr

Plugins · picture-gallery · data as of 2026-11-04

Is Picture Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.1)

As of 2026-11-04. 5 issues are on record for older versions; version 1.6.6 or newer fixes all of them that state a fix.

Latest version
1.8.1
Last updated
2026-10-30
Active installs
400+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Build a photo community with responsive galleries, PhotoSwipe browsing, frontend uploads and crop, resize, rotate and flip tools. — by videowhisper

What to do

  1. Update to the latest version (1.8.1). Anything older than 1.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get picture-gallery --field=version shows what you run; wp plugin update picture-gallery updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57696 · published 2026-07-23

Arbitrary file deletion in Picture Gallery (1.6.5 and older)

Affected
1.6.5 and older
Fixed in
1.6.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Arbitrary File Deletion in Picture Gallery <= 1.6.5 versions.

NVD CVE-2026-57696Patchstack advisory

high 7.1 CVE-2025-26581 · published 2025-03-26

Reflected cross-site scripting (XSS) in Picture Gallery (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.6.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in videowhisper Picture Gallery picture-gallery allows Reflected XSS.This issue affects Picture Gallery: from n/a through <= 1.6.3.

NVD CVE-2025-26581Patchstack advisory

medium 5.4 CVE-2024-13584 · published 2025-01-22

Stored cross-site scripting (XSS) in Picture Gallery (1.5.19 and older)

Affected
1.5.19 and older
Fixed in
1.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Picture Gallery – Frontend Image Uploads, AJAX Photo List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'videowhisper_pictures' shortcode in all versions up to, and including, 1.5.19 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13584Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-12696 · published 2025-01-18

Stored cross-site scripting (XSS) in Picture Gallery (1.5.22 and older)

Affected
1.5.22 and older
Fixed in
1.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Picture Gallery – Frontend Image Uploads, AJAX Photo List plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's videowhisper_picture_upload_guest shortcode in all versions up to, and including, 1.5.22 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-12696Wordfence advisoryCode change (fix)wordpress.org

medium 5.4 CVE-2024-34759 · published 2024-06-04

Stored cross-site scripting (XSS) in Picture Gallery (1.5.11 and older)

Affected
1.5.11 and older
Fixed in
1.5.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in VideoWhisper Picture Gallery allows Stored XSS.This issue affects Picture Gallery: from n/a through 1.5.11.

NVD CVE-2024-34759Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Picture Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/picture-gallery"><img src="https://laskyr.com/plugins/picture-gallery/badge.svg" alt="Picture Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit