Skip to content
Laskyr

Plugins · pgall-for-woocommerce · data as of 2026-11-04

Is 워드프레스 결제 심플페이 safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.6.0)

As of 2026-11-04. 6 issues are on record for older versions; version 5.5.18 or newer fixes all of them that state a fix.

Latest version
5.6.0
Last updated
2026-10-08
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

우커머스 결제 / 주문연동 및 교환, 반품 / 우커머스 매출 및 결제 통계 대시보드 / 리뷰, 구매평, 별점 자동 등록 — by codemstory

What to do

  1. Update to the latest version (5.6.0). Anything older than 5.5.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pgall-for-woocommerce --field=version shows what you run; wp plugin update pgall-for-woocommerce updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-95597 · published 2026-10-09

Missing authorization check in 워드프레스 결제 심플페이 (5.5.17 and older)

Affected
5.5.17 and older
Fixed in
5.5.18
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in codemstory 워드프레스 결제 심플페이 pgall-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects 워드프레스 결제 심플페이: from n/a through 5.5.17.

NVD CVE-2026-95597Patchstack advisory

critical 9.3 CVE-2026-56036 · published 2026-06-26

SQL injection in 워드프레스 결제 심플페이 (5.5.6 and older)

Affected
5.5.6 and older
Fixed in
5.5.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in 워드프레스 결제 심플페이 <= 5.5.6 versions.

NVD CVE-2026-56036Patchstack advisory

medium 5.4 CVE-2025-47661 · published 2025-05-07

Cross-site request forgery (CSRF) in 워드프레스 결제 심플페이 (5.2.11 and older)

Affected
5.2.11 and older
Fixed in
5.3.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in codemstory 워드프레스 결제 심플페이 pgall-for-woocommerce allows Cross Site Request Forgery.This issue affects 워드프레스 결제 심플페이: from n/a through <= 5.2.11.

NVD CVE-2025-47661Patchstack advisory

high 7.5 CVE-2024-56281 · published 2025-01-07

File inclusion in 워드프레스 결제 심플페이 (5.2.0 and older)

Affected
5.2.0 and older
Fixed in
5.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in codemstory 워드프레스 결제 심플페이 pgall-for-woocommerce allows PHP Local File Inclusion.This issue affects 워드프레스 결제 심플페이: from n/a through <= 5.2.0.

NVD CVE-2024-56281Patchstack advisory

medium 6.1 CVE-2024-11943 · published 2024-12-07

Reflected cross-site scripting (XSS) in 워드프레스 결제 심플페이 (5.2.2 and older)

Affected
5.2.2 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The 워드프레스 결제 심플페이 – 우커머스 결제 플러그인 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg() function without appropriate escaping on the URL in all versions up to, and including, 5.2.2. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-11943Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.4 CVE-2024-11228 · published 2024-11-23

Stored cross-site scripting (XSS) in 워드프레스 결제 심플페이 (5.1.4 and older)

Affected
5.1.4 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The 워드프레스 결제 심플페이 – 우커머스 결제 플러그인 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's pafw_instant_payment shortcode in all versions up to, and including, 5.1.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11228Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
워드프레스 결제 심플페이 vulnerability status badge
<a href="https://laskyr.com/plugins/pgall-for-woocommerce"><img src="https://laskyr.com/plugins/pgall-for-woocommerce/badge.svg" alt="워드프레스 결제 심플페이 vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit